Robot moving issue

All of our other subsystems are working, but when we try to drive using the logitech extreme 3d pro joystick the robot is unresponsive.

The error message is: teleopInit(): 0.006603s Shuffleboard.update(): 0.000013s LiveWindow.updateValues(): 0.001312s robotPeriodic(): 0.015209s SmartDashboard.updateValues(): 0.001451s Warning at edu.wpi.first.wpilibj.Tracer.lambda$printEpochs$0(Tracer.java:63): teleopPeriodic(): 0.002109s Warning 1 teleopPeriodic(): 0.002109s
SmartDashboard.updateValues(): 0.001451s
robotPeriodic(): 0.015209s
LiveWindow.updateValues(): 0.001312s
Shuffleboard.update(): 0.000013s
teleopInit(): 0.006603s
edu.wpi.first.wpilibj.Tracer.lambda$printEpochs$0(Tracer.java:63) Stop Intake Cmd Initializing! StopConvey Cmd Initializing! Warning at edu.wpi.first.wpilibj.IterativeRobotBase.printLoopOverrunMessage(IterativeRobotBase.java:359): Loop time of 0.02s overrun Warning 1 Loop time of 0.02s overrun
edu.wpi.first.wpilibj.IterativeRobotBase.printLoopOverrunMessage(IterativeRobotBase.java:359)

You won’t be able to get any help if you don’t post code for people to see, and then explain what you’re trying to do and what is the result.

Some code would be useful.

Some things that may cause no response.
USB controller mapped to wrong port.
Bad controller code
HAving both a command and a periodic method updating your drivetrain conflicting
having 2 commands updating your drivetrain. (use requires drivetrain for any command driving to avoid this)
Bad math in the command to drive the drivetrain,
attempting a pid with a p of 0

Make sure you are using the latest roboRIO image and WPILib. Joysticks not updating was a known issue in the first release.

Have you tried calling the ArcadeDrive method of the chassis. Rather than direct motor control.

1 Like

Specifically, since Differential Drive is set up on the drive motors, a Differential Drive method needs to be called periodically to keep it from shutting off the drive motors. Since your drive command doesn’t call a differential drive method, that’s why it isn’t driving. You can change your setMotors method in the Chassis subsystem to call the differential drive TankDrive method to solve this.

1 Like

Make sure your wpilib version is at least 2022.2.1 and roborio version v4. Our team had problems with not recognizing controller input and the new update fixed it.

Yes. We have everything updated to the latest version.

We tried ArcadeDrive before, and sadly it did not work.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.