Robot Moving When Enabled

Why does everything seem to go haywire just days before Bag Day?

I was testing the robot today, driving it with no problem. Then my team hooked up several Talons (SRX) and they were blinking Red and Orange (and the RoboRIO power light was red). In an attempt to solve the problem the Talons were removed and everything was wired back to KitBot configuration. I turned on the robot and everything lit up the correct color so I went to enable it just to make sure it still drove. Right when I clicked the enable button it started coming at me at a relatively good speed, I disabled the possessed robot. I placed the robot on blocks and tried again, the problem persisted.

Here is everything I’ve tried so far:
Restarting the robot (several dozen times)
Changing/Resetting Code (even through the code was never changed prior to malfunction)
Restarting the RoboRIO/Code (in driver station)
Checking all electrical connections
Looked in WebDashboard to see if it indicated a problem

I’m currently trying to get a priest to perform an exorcism but it is Valentines Day and we have a huge snow storm so they all seem to be unavailable currently.

Any suggestions?
I’d be more than happy to supply photos/videos.

Thank you for the assistance!

Red/orange blinking lights on the Talon SRX means damaged hardware. The red power light on the roboRIO indicates a power fault. That would indicated a wiring problem with your new motor controllers.

For your current set-up have you tried resetting your controllers? When you have the driver station up try hitting F1 with the joysticks centered. If that doesn’t work, you might try restarting the driver station computer.

Can you supply code?

Somehow after just continuing to restart it over and over it worked and hasn’t gave me the problem since.

Thanks for the help!