Robot Not Enabling

Greetings Friends,

We just installed the new cRIO II, and imaged and deployed our code, but when enabling the robot on the Driver Station, the DS says that the robot is enabled, but the Jaguars are still blinking instead of turning solid. The code is C++ on WindRiver and compiles, but I am wondering if this is a cRIO or other aspect of the control system that isn’t allowing the Jaguars to be responsive.

If anyone has any thoughts, please let me know! Thank you dearly.

1780

Does the DS show that the robot has code and is enabled? Is it in teleop? Can you put in some printfs or LCD messages or stay connected to the code in the debugger to determine what your code is doing?

Greg McKaskle

Yes, the DS has communication with robot and code, and successfully enables, but nothing results of it. I got frusterated and tried reimaging the cRIO but the imaging failed and corrupted the image so I am trying to successfully reimage it currently, but from what I remember there didn’t seem to be any errors other than a sporatic radio error in teleop. We tried both wireless through the router and then a direct tether to the cRIO but it was the same result.

Make sure that all three lights are on on the digital sidecar

For some reason, reimaging the cRIO always seems easier than debugging and fixing the issue, but it is rarely the cause of the issue unless SW is out of date. And because of the IP addresses, it actually isn’t that easy or foolproof to reimage.

Focus on reimaging the cRIO back to where you had it. You will need to put the computer and cRIO on the same subnet and ensure that other network options such as wireless are disabled and ensure that the wired ethernet doesn’t have more than one IP address set.

Then we can resume debugging the original issue.
Greg McKaskle

I think this happened to me at comp once. Someone must have pressed the space bar which is the emergency stop, and nothing was happening. We rebooted our cRIO and it worked. It may or may not be something as small as that.

Are the modules in the correct slots on the cRIO?

If you try to enable and the DS enables but quickly disables you could also check your periodic tasks or any other loops you have. Running the loops too quickly can cause that.