Robot not moving

Hi Everyone,

As of yesterday afternoon, our robot does not want to move. The code builds, it deploys to the robot, and we have communication. When we use our XBox Controllers, Driver Station recognizes what buttons/joysticks we are using; however, the robot does not move at all. We are coding in Java. We have made sure everything is updated: RoboRio, Visual Studio, Windows, gradle, etc. We have tried both with Wifi and with ethernet cable, we made sure all our firewalls are off (we use a personal laptop, not a school one), we tried different RoboRios and radios. We checked the fuses and we checked to see if all the wires were connected correctly. Is anyone else having this issue? Does anyone have any recommendations? The robot was working yesterday morning so I have no clue as to why it does not want to move. We leave for our first competition tomorrow so we are panicking right now.

Check and see if the robot code disappears when you enable, otherwise you need to post your code. Also maybe check vendor deps and motor controller firmware.

No, the robot code does not disappear when we enable it.

can you share a link to your code?

What status lights are on the roborio?

And your vendor deps and motor controller firmware are up to date?

Power, Comm, and Status are green. RSL is orange. I noticed the Radio light is not on.

We are double checking those at the moment.

We also have Talon SRXs and the classic NavX. Those are the updates we are checking for.

Do the motor controllers’ leds change color when you try to drive?

Also, is it a two-motor tank drive?

Correction: Status is not lit up.

No, the motor controller’s leds do not chage color. Driver Station recognizes the input, but the motor controllers do not. We have an arcade drive using two CIM motors per side - basic Andymark Chassis set up.

1 Like

If you are using the Talon’s in CAN mode, it could be vendor deps or the ids not being assigned. Can you run them through Phoenix Tuner?

Use this to trouble shoot status lights.

1 Like

Thank you! The Stat and Comm lights are orange, which means there is a sticky fault. Now we need to figure out how to fix it. The team programmer and I are novices when it comes to programming.

Okay, so we got them to turn green so we are making progress.

1 Like

We are trying to upload our code in GitHub, but it is not loading. When it rains, it pours.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.