deploy really slow

We managed to deploy our code up until today with relative speed. However after making some minor changes to code and duplicating files for GitHub to allow newer recruits to try, we discovered some line errors had popped up when trying to deploy. After fixing the culprit, Now when we want to deploy our code however it takes almost 5 minutes to actually deployed to the roborio . Any suggestions for improvement or why this would be?

edit also tethered via usb and wireless both offer same speeds.

When I was testing the deploy process earlier this week, it only took a few seconds to deploy my team’s code to our robot. Can you share the logs from the long deploy?

I will when I get back tomorrow am.

Just bizarre because it was going so fast until we hit one that pulled a line error. Then after it has ground to a halt.

Well, without any other information, my hypothesis would be you have a large number of files that you don’t need in your robot code directory. The deploy logs should tell you what files are being transferred.

Here is our log from deploy. This is following making the GitHub repository and other codes for students who are working on things.

Is that possibly what is slowing it down?

Edit. I just removed all but the deploy, and files. Still pushing 3 minutes for deploy.

Looking at the log messages, it starts connecting at 47:42, and connects at 50:47. That’s the problem. It’s weird because it is connecting via IP address, so it shouldn’t be very slow.

Might try disabling your firewall temporarily to see if that makes a difference – though it shouldn’t matter.

Maybe try accessing the web dashboard at and see if that also takes forever to load?

Another fun fact. We were trying it today and working code. The Windows PC would take two minutes (average) before it kicked the first log item. Following it took the additional time to actually deploy.

Using the MB Pro today. Almost instant deploys. Soooooo weird right now…

Any progress here? Did disabling the firewall help or make no difference?

Hi sorry for the belated reply, been out with sick children.

No difference changing the firewall unfortunately. I will see if I can try deploy again today and record a sample to show.

Talking with our alumni, he mentioned something similar happening in 2017, and just opted to deploy from Mac vs Windows with any changes. He too was unsuccessful at resolving it also.

Update So this might now be a RoboRio Issue. I tried deploying and setting up a second rio we are using for Autonomous Training and in using our Windows PC it worked perfect, and Deploy took only seconds. I go back to our Current Build Robot - and the Deploy is 5min still.

I really am baffled as to what might be causing it however, being the Mac Deploys are quick.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.