Robot radio wifi isn't working

Hi! Our team has been having some issues connecting to our robot in the past week. Using robot radio wifi (which worked a few weeks ago) gives no comms, but robot radio, robot, wifi, and firewall are all green on the driver station when connected to the wifi. Computer directly to roboRIO by USB works, though. And I might be wrong about this, but I’m pretty sure another computer was able to connect to the roboRIO by robot radio. Is there anything that we’re missing?
Thanks in advance!

Is your team number set correctly in the driver station? If I recall correctly we also ran into this issue after updating to the new version and that was the fix.

1 Like

The team number is okay for driver station.
But yeah, I think it is something wrong with just my computer. Tested again today and someone else was able to get comms…

Make sure all firewalls are off, or at the very least, that Windows is classifying the network as Private.

Hi! The firewall light on the driver station is green.

Were you ever able to figure out this issue? We are having similar problems and have tried everything we can think of. It’ll connect over over USB, but not wireless or ethernet.

We did not…did you try using a different laptop?
Sorry for the late reply :slight_smile:

Did the failure happen after a competition?

Maybe you all know this, but you need to reflash the radio back to non-competition (“normal”) firmware, otherwise you won’t get anywhere. You should also probably not turn on the firewall in the radio (different from the firewall in the DS); it just blocks useful features like ping, and downloading robot code.