Robot Randomly Disconnects (2020)

Our mecanum robot running TALON SRX randomly disconnects after enabling it, and especially when we move the robot violently with the control, or “jerk” it. Once disconnected, it stays disconnected for about half a minute, and then connects again and works perfectly until another jerk, or sometimes randomly as well. This only happens after we enable the bot. We know it isn’t the radio’s fault as we switched radios, reconfigured, and tried with ethernet and in all cases the same error occurred. We also reconfigured the roborio, factory reset it, and still the error persisted. We really don’t know where to go from here, since our electrical team thinks the wiring isn’t the issue. Any ideas would be greatly appreciated.

It could be a RoboRIO reboot. Is your 10A fuse fully seated in the PDP (e.g. pushed in all the way HARD… you shouldn’t be able to pull it out by hand)? Also tug test the power wiring between the RoboRIO and the PDP.

And tug and wiggle among the Battery to SB50 to breaker to PDP and back circuit. There should be no movement of the wires at any of the junctions, only flex of the wire itself.

3 Likes

We also had this problem and it turned out to be that our roboRIO was losing communication with the wifi access point because the router’s power wire was not seated in the VRM correctly. Cutting and restripping the wires helped and then putting them back in the VRM fixed our disconnection issue. Hope this helps!

Have they checked all of the wires, fuses, and breakers in the power path of the radio and RoboRIO, and I mean ALL of them? Not to be too harsh, but with this type of failure, “We think” is worth about as much as a handful of pocket lint. They need to know, 100%.

30 seconds sounds like a RIO power issue, but could possibly be a radio issue. The hard motion to trigger sounds very suspiciously like there’s a loose wire that’s getting dislodged briefly, just enough to cause a reboot.

What do the logs point to? https://docs.wpilib.org/en/latest/docs/software/driverstation/driver-station-log-viewer.html#identifying-common-connection-failures-with-the-log-viewer

We had this last year and found a poorly seated wire in the PDP to VRM connection.

Also, do the lights in the radio or roborio go off?

Have someone(s) ready to quickly look into the bot to see the status of a couple of lights. When you “jerk” the bot and cause the disconnection, quickly look at the lights on the roboRIO. Is the “Status” light lit red and then goes off? That is the roboRIO rebooting and loading firmware. Is the power light on the radio now flashing? That means it is rebooting. If only one of them is happening, the problem is in the power wiring for that one device. If both are happening, then barring multiple issues, the problem is in something common between them.

roboRIO rebooting - Check the power into the PDP including the fuse being fully pressed in HARD (if your finger doesn’t hurt pushing it in, it isn’t in enough). Also check the power connector in the roboRIO is fully inserted and screwed down along with the wires being fully screwed in.

Radio rebooting - Check that the power wire is correctly inserted into the VRM in the 12V 2A ports. If using the PoE injector, make sure that the wire is actually crimped into the ferules (my team discovered that last years injector did NOT have them crimped only a couple of days ago…removed the useless ferules and inserted directly).

Both indicating reboot - Problem is further upstream. Check every, and I mean EVERY, power connection from the battery through. There should be no mechanical movement in any electrical connection, with the exception of slip rings maybe. Check the battery terminals. Check the Anderson connectors. Check the main breaker lugs (this is the one just about everybody misses since they are normally covered in layers of tape and forgotten). Check the lugs into the PDP (the ones under the cover). Check the VRM power out of the PDP including the fuse being pushed all the way in HARD.

When checking electrical connections, be observant in whether a crimp is actually doing the job. If the wire is moving appreciably right next to a crimp, the wire itself might not actually be clamped down on. This is especially pertinent for the 6ga connections as not many teams seem to have the correct tool for doing those lugs properly (solder is not a solution and can actually cause them to be worse).

When going over the whole thing, tug tests on each wire is a good thing, but so is a wiggle test. That can show shorts between polarity that may be the gremlins stopping your robot.

3 Likes

Some more electrical checks.

Do the pull test on individual wires, not a wire pair. If one is loose, it may feel secure if the other in the pair is secure.

Use a flashlight and look around all the Wiedmuller connectors for anything shiny. This could be a stray strand that did not go down into the hole in the connector and can cause a short to the adjacent wire. The strip length for the wires going into the Wiedmuller is 3/8". A bit of the insulation should go down into the hole. If you don’t strip enough, the clamp might not hold the wire securely or may clamp onto the insulated part. If you strip too much, some part of the bare conductor will be exposed outside of the connector leaving it vulnerable to being touched by a stray strand from an adjacent wire.

Open your rio and vacuum it out/check for very fine metal shavings. We had similar issues/behavior in 2017.

This happened to us in a match, I would recommend teams adding this to your preflight checklist.

2 Likes

A lot of people seem to be suggesting Rio reboot, which I’d also suspect. You may want to check radio power, because if I remember correctly it’s around a 20s reboot time so it could be that

another thing people tend to skip over is checking the breaker. We had the problem before where the nuts connecting the wires were not tight and lost the connection when the robot jerked like you had said.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.