Robot Unresponsive

Help!
We had our robot working, then took it apart and rewired it. Now, although we had the jaguars running earlier today, now they are not responsive although the yellow light is solid and lighting up. We have reimaged the crio and uploaded the default code control program. The jaguars will not make the motors move with joystick control or in autonomous mode. What should we try next? any input would be greatly appreciated.

Team 4200

One idea for Teleop is to check on the Driver Station Setup tab to see if the arcade joystick is associated with the correct USB port 1.

Press a button on the joystick and it will light up blue on the Setup tab so you can see where it thinks it is.
If it needs to be move, just click, hold and drag.

The default code doesn’t have any autonomous defined. The code that’s there is disabled.

The joystick is in the right USB port, and was working fine before (we had the robot moving in arcadeDrive mode just fine). Also, we wrote our own autonomous code, and that’s what we tested with. The lights on the Jags stay solid yellow, and do not change to green or red. All of the Jags are connected to the correct motors, and are in the correct PWM ports (1,2,3,4). We have no idea what’s going wrong!? :confused:

Sounds like a code problem.
To test, use a pristine brand new project then Build and Run as startup.
See if it shows the same issues.

Are there any error messages on the Driver Station Diagnostic tab window?

There are no errors in the driver station diagnostics. Also, the defaultcode program that we used had no changes to it (and the ports on the sidecar were correct based on the program). The issue is persisting, no matter what program we use. :frowning:

Check the PWMs, they may be backwards

All three Digital Sidecar power lights are bright green?
Is the Robot Status Light doing anything interesting?

Are you using the same 37-pin cable as before when it worked (did you have to reverse yours)?

I’m leery of the default code you’re running that’s had so many modifications made to it, e.g., 4 PWM outputs, autonomous code.

If the Jags are solid yellow, then they are getting a good PWM signal.

The Digital Sidecar lights are all bright green. The status light on the Crio is not on (is this normal?). We are using the same 37 pin cable as before. We tried our own program too, and still nothing works. We tried using the program with a Vex motor module, but it didn’t do anything either. (Meaning the problem is not the Jags). :confused: This narrows it down to something with the Sidecar or the Crio, but we can’t figure it out.

cRIO must have a green status light or the cRIO is not powered.
Try measuring the 24v voltage into the cRIO at the connector to see what you get.

If your power is good, then there’s a possibility of metallic debris inside the cRIO case shorting things. It can be opened and cleaned out if you are careful handling the single board. Here are some cleaning directions. If you still have the gaskets from a past year’s KOP you can install those to help keep metal dust out of the cRIO case.

Thank you! :slight_smile: we will try tomorrow