RobotBuilder not displaying correctly

I am trying to use robot builder in eclipse but when it launches the font is to small to read.

I looked online but could not find anything. Any suggestions?


Hey there,

I ran into this problem over the summer, and the only thread about it I could find on Delphi was closed after no solutions. I avoided using RB for the time, but later was reintroduced to the problem due to a different program.

The short answer - This is an issue with windows 10 and how programmers set their programs to scale for high resolutions. Finding a different computer without the issue might be easier.

Disclaimer I am the king of following online tutorials without understanding what’s going on. Follow at your own risk, and make necessary backups to avoid damaging your OS. The solution has you make edits to the registry and important Java files.

The workaround - Since RoboBuilder uses Java, you have to follow the steps on this site to make an updated manifest file for Java. The problem I see with this is that it might make any other Java programs look or act weird. I used this mostly for a different program, so I didn’t test it too much with robobuilder and Java. It does work though. I tried it to see so I could post the workaround here, but never got around to it. I’ve uninstalled eclipse and RB since then so I can’t show you how it looks. This is the address of Java on my computer in case that helps you find it on yours C:\Program Files\Java\jre1.8.0_151\bin

Hope this helps you and anyone else who has the issue! Also if anyone has a better solution, please let us know!

I went back a grabbed a screenshot of what ResourceHacker looks like after you open Java.exe. I highlighted the line that should be edited when making the new manifest file for Java. Copy and paste everything into a notepad file, change ‘true’ to ‘false’ in the highlighted code, and save just like the instructions tell you too.

I have had this issue as well on student laptops with very high resolution screens. Our workaround is to drop the resolution settings of the display (e.g., from 2736x1824 to 1380x1024). You need to log and back on again for this to fully take effect.

I also noticed that when I connected a second screen to my laptop and extended the desktop screens the laptop screen and the external monitor, which had a resolution lower than the laptop, this also seemed to resolve the issue.

Hope this helps and that someone updates RoboBuilder to display correctly on high resolution displays.

@Djames, thanks for your help, that fixed the issue I was having. 17, thanks for your help.