Robotpy Upgrade not working on MacOS

I’ve recently tried to upgrade my local MacOS environment (Intel MacOS Monterey 12.2) to the 2022 robotpy release, but had no success. I’ve tried the following, but always end up on 2021.2.9:

  1. Running pip3 install --upgrade robotpy
  2. Uninstalling robotpy, and reinstalling
  3. Creating a new, fresh, virtual enviroment, and installing.
  4. Using --no-cache-dir to prevent pip from using local versions.
  5. A combination of all 4 above techniques.

Here are the first few lines of terminal output from running Step 3 followed by Step 4:

$pip3 install --no-cache-dir robotpy
Collecting robotpy Downloading https://files.pythonhosted.org/packages/75/9c/317c4028d4db1e6102cc152ba75f0c1913fca9c4ba8a096cf27a3e6aceb5/robotpy-2021.2.9-py3-none-any.whl ...
Any suggestions? I’ve run out of ideas. Thanks.

What version of python? What’s the full output from:

  • pip3 install -v robotpy
  • pip3 list
  • pip3 install -v 'robotpy>=2022.0.0'

My initial suggestions are:

  • Make sure you have the very latest python installed (3.10.2)
  • Make sure you have the very latest pip installed (22.0.3)

Usually the version of python/pip aren’t terribly important, but since OSX 12 was only released a few months ago it’s possible that older versions of python/pip won’t properly support it.

Was using Python 3.6, 3.10.2 fixed the issue (I had previously upgraded pip as well). Thanks!