Romi Camera data blank in Shuffleboard

I’m using the romiReference project and the “Built-in multi camera streaming” application from the Vision Application Configuration panel at wpilibpi.local. When I start Shuffleboard I can see the Camera Publisher data in the Network Tables and the “rPi camera 0” under the CameraServer dropdown. When I pull the camera stream onto a Shuffleboard tab the image is blank.

The strange thing is that it was working at one time. There are no code changes on my part since everything is out-of-the-box. The only thing I did was upgrade to gradleRIO “2021.3.1”.

Does anyone have ideas on how to troubleshoot this?

This is unfortunately a known issue with Shuffleboard’s camera displays in general. Reports say pressing the record button at the bottom sometimes makes the streams come back.

It’s actually a bug with the cscore camera logic. It’ll be fixed for 2022. Smartdashboard doesn’t have the issue because it only uses cameraserver

1 Like

Thank you for your response. I’ll display the camera stream to a Webpage until 2022 is released. On a related issue, I tried this on a Windows laptop and the CameraServer data from the Romi doesn’t appear in the Network Tables at all. Is this also a bug or is there something that I have to configure on Windows. I’ve been using a Mac up until this point, but most of my students use Windows.

That’s probably due to a firewall issue–when running with the Romi, your code (and thus the NT server) is running on your desktop and the Romi is trying to connect to your code. Make sure your firewalls are disabled.

1 Like

I was going to post this as well. It is entirely possible for all the web socket pieces to connect (onboard sensors et al) amd the NT pieces not work (any robot to shuffleboard communication which includes vision.

The firewall on the Windows laptop is disabled and the Romi still doesn’t connect to the Network Tables. I’m not a Windows user, I just borrowed this one to test it, so I’m a little out of my depth on that platform. The Romi is setup as an access point (10.0.0.2) and I can ssh in from the Windows laptop. My Macbook works perfectly with Romi, so it doesn’t seem to be a problem with the Romi.