Router/Radio will not flash

Cannot get radio to take new firmware.
Says it has no image for something we have given it

Why are you trying to flash with the command line?

2 Likes

Can you use the graphical image configuration instead of from command prompt and tell us what the error is from there?

1 Like

Because the GUI didn’t work.
Sure. Will post tomorrow

1 Like

Another thing is, I almost always have problems flashing the radio. I usually power it up with nothing plugged in, then plug in the Ethernet after the light is stable then flash once it’s connected.

It’s a whole process to make it work.

This might be a stupid Q, but how do you power it up without plugging it in if it’s POI? There is no AC/DC converter supplied with it.

Currently, I have mine hooked up to the power distribution board with a battery. You can follow the steps on how to do it or you can find a 12V source that you can plug into the wall.

If you plug it into the distribution board, you’ll be able to play around with more electrical stuff down the road.

Preparing to load fimware
Error finding NPF device name for adapter: Realtek PCIe GBE Family Controller #2
Try disabling all other adapters (using the Control Panel)

When I flashed our radios, I removed power to the radio and plugged in the network cable going from the router to the PC. In the software I would then go in and select to flash the radio and didn’t power up the radio until after that point. Mine wouldn’t flash until I did it in that order.

EDIT: When I was saying “flash”, I should have said “Load Firmware” like the wpilib screensteps call it.

1 Like

Have you disabled all network adapters except the one you’re plugging into the radio? See the “Troubleshooting: Disabling Network Adapters” section at http://wpilib.screenstepslive.com/s/currentCS/m/getting_started/l/144986-programming-your-radio#Troubleshooting-Disabling-Network-Adapters for instructions on the right way to disable network adapters - if on Windows 10 you need to make sure you use the “old” control panel.

Yes. Used the old control panel, right click, disable with the admin shield.

‘Router’ and ‘radio’, do you mean the same thing, the white radio?

Are you sure that the ethernet port on the coumputer is good?
If so make sure everything eles is disabled and I would recommend restarting the counputer

Let me get this straight.

  1. orange POE cable plugged into port next to DC power port. This gives the blue power light.
  2. unplug the orange POE cable and connect a standard ethernet cable (not the POE split cable) from computer to port furthest from DC power port. At this point, all the blue lights on the radio go out
  3. Flash radio w/all network adapters disabled except for the one connected to the radio
    Correct??
    Also, I have an ethernet or LAN option in Network Interfaces
    Which one do I choose?

Here’s our setup:

  • Orange PoE plugged into port not directly next to DC power port.
  • Ethernet cord going from a computer into the port closest to the DC power
  • Launch Radio Config Utility
  • Select the first network interface that pops up. (If the configuration fails, try any other network interfaces that appear in the list)
  • Load Firmware first
  • Configure, if loading the firmware is successful

If you run through all of your network interfaces and it doesn’t work, try out a different computer.

Good luck!

We could not get the firmware flashed using the orange PoE injector at all. When we switched to using the barrel plug, it flashed just fine. I’d suggest attempting to flash without the injector (one came in KoP this year), in addition to the suggestions provided by other posters.

Thanks! The instructions leave out a lot, namely the fact that you’re using 2 cords plugged into the radio and The pic on the instructions is wrong. I think your #2 bullet should be “farthest” not closest, yes?
NoMythic 2491 helped us out. We did as above. The pic in the radio config utility is correct. We did have to unplug the POE and then plug it back in. Took about 5 min as opposed to the 2 hours we spent trying to get it working on our own.

This worked. I didn’t realize I needed 2 plugs, the POE and the cord to the laptop :confused: