After we got back from nationals, we couldn’t get get the router to work. We don’t have a back up router to check if it is the router. We are in the process of changing our old bot to a T shirt shooter. It works with the Ethernet cable connected.
The IP addresses are correct. Any suggestions?

Yep. You need to shut off the WPA encryption. (I believe that how to do that is in the documentation for the router; I don’t recall offhand how to do it. Might be something with the configuration utility.)

And don’t worry, you’re not the only team who’s run across this little issue. Someone gets caught by it every year.

Have you reset it?

After competition, you have to reset and reconfigure the radio (to remove the encryption used at competition). Reset the radio with a paperclip/small allen wrench, and then configure it (the same way you did to practice with the robot during build season).

Another tip to make this easier in the future is to export a configuration file on both the wireless bridge and your router, and upload that after you do the factory reset.

You can run the non-competition version of the FRC Bridge Configuration Utility (which was included in this year’s NI Update) to reset your router with the right settings for use at your shop.

And for doing things the manual way:

  1. Flip the switch on the back of the router from ‘Bridge’ to ‘AP 2.4Ghz’.
  2. Reset the router (Hold down the reset button for ~10 seconds while it’s on, release, then wait for the reboot to complete)
  3. Connect to the router (Ethernet is easiest), launch a browser, and open
  4. Log in (The username is ‘admin’ and the password field should be empty)
  5. Skip the setup wizard by clicking “Wireless Settings” in the left side
  6. Change the ‘Wireless Network Name’ from ‘dlink’ to something else (usually your team number)
  7. Make sure ‘Security Mode’ is set to ‘None’
  8. Go to ‘LAN Settings’ and change ‘IPv4 Address’ to your team’s IP (of the form 10.xx.xx.1 where xxxx is your team number- for my team, that would be or just
  9. Make sure ‘Subnet Mask’ is, and hit ‘Save Settings’
  10. Now, click the ‘Advanced’ tab at the top, and click ‘DHCP Server’
  11. Click ‘Enable DHCP Server’ and set the range from 10.xx.xx.2 to 10.xx.xx.100 (Again, for my team, that would be to
  12. Make sure ‘Default Subnet Mask’ is and set ‘Default Gateway’ to 10.xx.xx.1
  13. Hit ‘Save Settings’ again

After a reboot, everything should work! Connect your driver station to the WiFi name you chose and you should be able to control the cRIO!

Thanks for all your help!