RSL Doesn't work

I know this is really late to have a problem like this… but our indicator light doesn’t seem to want to light. The light beside the RSL is working, and I’m even getting a voltage reading at the light, but the light doesn’t seem to turn on.

I found it funny, though, that I was only getting about 5 volts at the light when the light was supposed to be 12 volts. I tried hooking up the light to a power supply and it worked at 12 volts, but failed at 5 volts.

Any insight would be appreciated.

Make sure your Digital Sidecar is getting a good 12 volt supply from the Power Distribution. It needs to be wired from a pair of terminals protected by a 20A circuit breaker. Don’t just look at the wires to verify they are where they need to be – actually measure the power on the white connector going to the Digital Sidecar.

We’ve seen a # of teams who don’t remove enough insulation from the power wire for the Digital Sidecar (at the PD end of the cable) and, as a result, they only receive “phantom power” for the Digital Sidecar via the 37-pin ribbon cable.

It may also be possible that you’re power leads are swapped and you’re applying -12V to the Digital Sidecar. The module has protection for this but you’ll probably still observe “phantom power”.

All 3 power LEDs near the RSL port should be strongly lit when properly powered.

Please do as Alan suggests - use your meter to confirm the 12V supply to the Digital Sidecar. Then check for insufficient stripping and reversed leads.


OK, problem solved. Someone decided we should push 5v to the sidecar instead of 12v. So we put 12v in and it’s working fine. I’m not sure how we had it working so well this whole time…

The sidecar will sorta-mostly work in a variety of configurations. We should add this to Vince’s list of “things not to do with the new control system”. Fortunately, none of them have been reported to break anything, just not quite work right.