RSL not blinking and Relay not getting signal

Our RSL isn’t blinking, it’s solid no matter what mode it is in. It was blinking before we modified code and then we modified code and then it went bloop and is now on all the time once communication is established.
Furthermore, the spike is not getting relay signal even though the code was not modified when it was working.
Any suggestions?

A loose 37-pin connection at one end or the other would do this.

If you made the ribbon cable yourself, it’s possible it got screwed up somehow?

Our RSL and a couple other devices did the same thing at competition last year and the culprit was our poorly-made cable:/ Ended up just using the huge, fat cord from past years.

I’ve tried two different ribbon cables now, it didn’t solve anything. Thanks anyways.

We haven’t made the cable, it was a KOP one.

I have to ask…Are there three bright LEDs on the DSC? What you describe often is a case of the DSC not getting power. There is also an LED on the DSC next to the RSL connector, it should flash at the same time. If it is not flashing, the RSL will not flash.

Yes. All lights are on and the little LED on the DSC isn’t blinking, it’s solid.

Is the Driver Station in Autonomous?
The RSL is solid during Autonomous.

If that’s not it then…
No error messages on the Driver Station Diagnostic tab?
Communication & Robot Code lights are green?

The RSL is not directly affected by user code.
The FPGA blinks it according to what it’s told by the cRIO FIRST communications layer based on the field mode (Disabled, Autonomous, Teleop).
There are other error codes, such as a fast blink if it isn’t communicating with a Driver Station at all.

Yes, Com and Code lights are green in the station. The light is solid once we turn it on immediately, and it doesn’t change.

You can try running some default code to eliminate (or isolate) code as the problem.

On the electrical side, I’d move to inspecting the cRIO module connection with the main chassis.
If it’s an 8-slot cRIO were the sealing gaskets ever installed? Metallic dust that has worked it’s way inside the case can cause odd failures when noting has changed.
If it’s a 4-slot cRIO, then it’s conformal coated, so metal dust and debris wouldn’t be suspects.

The NI 9403 Digital I/O module is correctly installed in the second cRIO slot, isn’t it?

We’ve installed the 9403 in the second slot. Like I said it was working until we put it away.

hey this is one of hunter47’s team mates just an update, our RSL light isn’t responding, the code works according to him.

Yes the code does work correctly now, everything works correctly except the RSL. Probably able to be solved with a DSC.

If everything else works (PWMs, Relays, DIOs), then it probably is damage inside the DSC.
If you have a second DSC it’s an easy test. Just the 37-pin cable needs to be connected to see if the RSL is operating properly.

We actually have 3 and one is has the same problem and the other’s light doesn’t come on at all.

The one that actually works the best is labelled as “non-functional”… haha