servo jitter when running Jaguar on RS-775

This year we used servos for our grab mechanism, and also as a latch for the deploy table. We had trouble with them moving when we didn’t tell them to.
This was from two issues:

  • The servos are initialized to a position when they are opened (I made a programming workaround for this)
  • When moving our arm, the sevos jerk around spontaneously (the topic of this thread)

Let me give more detail.
Our arm is powered by an RS-775 on a p60 (4:1) with a jack screw. When we drive this motor, the servos jerk around. It happens more when the motor is moving than when the motor is stalled. (When I say stalled, I’m not talking about full voltage. We had some binding issues on our arm, but it wouldn’t stall continuously at greater than 30% power)

I think I know where the issue is coming from - it’s from the 6v power supply on the Digital Sidecar. (The other option would be the PWM buffer in the digital sidecar) Removing the DB37 and putting in a fresh battery have no effect, but removing the 6v jumper to a servo stops it, as does disconnecting power to the whole digital sidecar. (Our Jaguars are controlled over CAN)

What I don’t understand is WHY this issue is happening. It’s not unique to a single digital sidecar. Our 2010 DSC did this, and switching it out to a 2011 DSC made no difference.

At this point you might bring up the issue with the RS-775 shorting between its windings and its core (thus connecting to the frame). I haven’t tested this on our RS-775 (having just learned about it yesterday), but I can tell you the servos and DSC are in no way connected to the frame.
I also haven’t had the chance to put an oscope on the 6v and 5v power supplies on the DSC. So, until we’re off of spring break, this is mostly speculation.

Ah yes. We’ve seen this for years, both on the old IFI control system, on the new one and even on our old RC cars that we drive around.

If what you’re seeing is what we’re seeing, then I believe the culprit is a possible combination of several things.

The 775’s are fairly noisy motors. We’ve had good success in the past with damping the noise down with appropriate capacitors. There are several threads here about it. Al from 111 made a suggestion as the size requirement - I can’t remember it off hand.

Another issue that we dealt with in 07 (our camera would shudder when we ran our drivetrain) was that the PWM wires feeding the servos were too close to the motor power wires that ran our arm joint.

A combination of capacitors and rerunning the pwm’s fixed our problem.

I haven’t seen the issue you are seeing with the servos and their initial position. I’m assuming that you’re using labview: have you set their position IN the begin statement? That’s where we initialize all our actuators, and we’ve never had an issue with the HD servos moving.

We really need Eric van W. in here to explain the internal wiring of the PD and DSC components. Do they all share the same unfiltered ground?

the problem is probably that the wires for the servo and the RS-775 are parallel and too close together. the wires act as a capacitor because you have two conductors separated by a insulator. since the current levels are fairly high, you might have enough induced current to jerk the servo.


We are experiencing the same exact issue you described.

We use 2 servos, one to release the deployment system, and one to release the actual minibot. In both cases the servos would jitter as we ran our two 775s for our elevator system.

After discovering our 2nd set of motors both had internal shorts (the 1st set did as well), we managed to scrounge up 2 more 775s that were sans-short. Since replacing those motors the problem has gone away.

It was an extremely frustrating problem because we had no idea when/if the deployment system would trigger as we ran our elevator.

I’ve noted the other suggestions in this thread, but I know for a fact the wires running to the motors are not close to the PWM servo cables. The capacitor may be a helpful solution, we’ll have to look into it as a fall back.



As for induction from wire to wire, that’s a definite no. The wire runs don’t even come near eachother.
However, I suppose (if the 775 is shorted to the frame) it could be induction (or capacitance) from the frame onto the wire. I suppose the way to tell would be to power the DSC from a seperate battery, and see if the problem still persists.

Yes, I ended up setting the Servos to “disabled” in I had assumed they were initialized to that automatically, but apparentally not. (I’ll admit the way I’m controlling them is kind of weird. Since we were prototyping our grabber using the FTC servo controllers, I made the FRC code use the same values, by converting the servo reference to a PWM reference, and setting that value directly. However, this does give me another advantage: I can disable the servo by setting it a PWM value of 0)

Further evidence that the Banebots chassis fault issue is actually a bigger deal than Banebots wants to admit.

Teams, please check your `bots for this.

When we were having the issue, I was able to isolate it to the 775s by pulling their breakers and disconnecting the leads (separate actions- as to isolate the jag). Both of these things did away with the jitter.

Interestingly enough, of the two servos we had connected, only one PWM port was driving the jittery one. Switch PWM port, the other jitters.

Yeah, not to pile on, but we just pulled 4 banebots new out of the box. 1 had a case short, and 2 had bad bearings - with a slight outward load on the shaft the motors would lock up hard and not rotate at all.

I am going to throw a guess on this one where the Jag breaker isolates it and switching PWM servo outputs moves the problem. The Jag is capable of very high rise times and therefore is likely to put some wild RF signals on the motor leads. If the 775 has a case short, caps across the motor leads will not help. I have experienced noise currents traveling on wire and then crossing over to another wire and causing problems. Sometimes, RF ferrite beads around the conductors can shunt the noise. My suspicion on the 775 problem is that you will find it to be a greater problem when driving in one direction vs. the other. If that is indeed the case, then there are significant currents driving through the case to the common electrical lead on the Jag and back out to anything connected to the Jag with the same common terminal.

Your guess seems right to me. Our servos only showed the issue when the elevator was driving up (aka: under the largest load).


Has any one tried adding a cap to the servo wire as close to the servo as possible? While it may not work in this case, It has solved twitchy servo problems on some of my projects in the past. Cap on the + and - .

I’ve taken of the RS775. It did indeed have a short to its case. (About 1 ohm)
There was nothing else connected to the frame, but considering the long servo runs, I don’t doubt that the servos were jittering from induction onto their signal line.

I’ll get around to testing sometime.

Tom -

Do you remember what port jittered and what port was good?