Servo Porblems

We got a problem in the Servo.

we put up the Jumpers, we checked our program a million times, we also tried to switch the direction of the wires, nothing is working!

It used to work, yet for some reason it recentally stopped working.


Check the state of the RSL and try out the Diagnostic Window.


Does the cRio have to have the Labview image in it to be able to use the diagnostic window or can it have the WindRiver image?

coughs You switched the direction of the wires? I hate to break it to you, but you might have fried your servo. They don’t really like being plugged in backwards. Try to get your hands on a known good servo, and make sure you plug it in correctly.

I would also recommend that you try known good servos, but plugging in a servo backwards is not likely to fry it. The PWM (servo) cable has the following signals:

(Black) - (Ground)
(Red) - (Power)
(White) - (Signal)

Reversing the cable would only lead to switching the Ground and Signal wires, meaning that - worse case scenario - the servo detects no control signal and the PWM signal may cause some weird behavior due to “dirty power,” but as the voltage across the servo would never exceed the standard operating voltage, I doubt it would damage anything.

Pretty sure the cables were designed this way on purpose.


The Digital Sidecar Status LED is steady on.
Measured 1V between red and black wires and there is also a signal on the signal wire.
Still the servo doesn’t work.
Have any idea what’s wrong?

We had something like this happen the first week we had the cRIO & digital sidecar.

We forgot to power the digital sidecar. Once we added power it worked fine. Not sure this is your problem - but might be something to check.