Set up Phoenix Tuner using Raspberry Pi

Our team is working on the motor controller program using Victor SPX, Talon SRX, CANable, and raspberry pi 3. We have read the extensive documentation on the supplier website. We are currently using the CTR Electronics documentations to set up the Linux robot controller. We were able to validate socket can functionality, our CAN devices were blinking orange. However, we have not been able to set up the phoenix tuner. When we follow the instructions we get an error stating that the remote system is not supported. Both the laptop and the raspberry pi were connected to the same wifi. We turned off all the firewalls in the laptop. We then tried using a desktop computer and we continued to get the same error message. See the image attached. What else can we try? Do we need to connect them using an ethernet cable? What procedure should we follow? Are we able to control the motors without using Phoenix Tuner. Thanks in advance for your help.

1 Like

Your best bet will be to contact CTRE for Support: http://www.ctr-electronics.com/contacts-us

In the meantime, if anyone has set-up the phoenix tuner with a Linux device before suggestions would be apprecitated.

Working on it again today, we are getting a general error and it saying Lost Comm. We’ve tried running the connection off of the ethernet alone and it took longer before the program lost comms again. Could this be a problem with using the wrong connection or IP?

I’ve run into the same issue. Here is a workaround that has worked for me.

  1. In Tuner, enter the IP of your Pi and run the temporary diagnostics server (as if the PI were a RIO). This will allow you to enter the user name and password for your PI, but will ultimately fail because your PI is not a RoboRIO.

  2. Now install the diagnostic server per the documentation. Tuner has saved the username and password of your PI from step 1, so it should now be able to ssh into the PI. This will look like it succeeds, but the server will not start correctly.

  3. The final step is to close Tuner and re-open it. Then click the button to start the server. Everything should work.

Note that the Phoenix RPI libraries have not been updated since November and do not support Talon FX’s, so you won’t be able to control any Falcon 500s from Tuner. I have found that I can treat them as SRX’s in code, and basic functionality seems to work fine.

We’ve actually been testing a fix for this internally, and we just released it today:

Also:

We publish binaries for all of our platforms for every release in our maven repository:
https://devsite.ctr-electronics.com/maven/release/com/ctre/phoenix/

The Linux-SocketCAN-Example on GitHub doesn’t get updated as frequently, but you can always pull down the latest binaries and headers from maven and include them locally.
Note that if you update to the latest (any 2020 season releases), you’ll need to include two additional binaries that were new this season - Phoenix-core and Phoenix-diagnostics.

If you do update, make sure to use Tuner to Uninstall the Diagnostic server before running your project, as the two versions of diagnostics will conflict. We have a solution to this that will be coming with a future release, which is when we’ll update the GitHub example for linux.

2 Likes

We downloaded the new version for the tuner and still we can’t connect. We are connected to the same wifi and are entering the right IP address of the Raspberry Pi. The error states that it could not connect and that it could not retrieve the version information. We tried connecting using 2 computers and we got the same error.

Are you able to ping the IP address you’re using from the computer that Tuner is on?

Alternatively, you can use the name of the raspberry Pi to connect.
ie, when you open a terminal on the Pi you’ll see username@hostname: - you can use the “hostname” for your Pi instead of the IP address and mdns should find it.

Pinging will also work using the hostname or the literal IP address. If you cannot ping the IP or hostname, Tuner will not be able to connect.

1 Like

Yes, we are able to ping the ip adress using the computer that the tuner is on. Error.pdf (16.9 MB)

1 Like

Send a screenshot of your entire Phoenix Tuner window (after failing to install diagnostics) to support@ctr-electronics.com.

I have a feeling something strange is going on in your setup, but we can confirm and troubleshoot via support.

I sent an email to support@ctr-electronics.com that way we can troubleshoot via support.

https://phoenix-documentation.readthedocs.io/en/latest/ch06b_PrepLinuxRobot.html

This article is really helpful feel free to check it out for more information that you can use on this project.

1 Like