Setting Up 2010 Camera

Hello everyone,

Our team has gone through several steps in an effort to get camera feed to show up on the driver station, but to no avail. We’ve been through default camera demo code, and the most common response on this forum involving “AxisCamera&.” Can anyone tell us what it is we have to do to get this to work?


P.S. If it helps, we can’t ping the camera when it is connected to the robot (through, so that may be the problem, but we don’t know if it should be doable or not.

The cRIO ethernet ports are not tied together, so you cannot ping from one network to the other through the cRIO.

To help debug, connect the camera to the PC and set the PC network to be on the same subnet as the camera. You should then be able to ping, you should be able to use a web browser to log into the camera and test and configure, and you should be able to run the camera setup app which will help you create the user account on the camera which allows WPILib to request images and control the camera.

At that point, move the camera back to the robot and see if you get images back to the dashboard. If not, verify that you have the most recent dashboard with the compass-like direction display on the bottom of the panel. If not, uninstall and reinstall the driver station update – there were issues with the update installer replacing files already on the classmate.

If you still have issues, post the results of these tests and more description of the symptoms.

Greg McKaskle

This post should be stickied. It took us three nights to do exactly this. We had already installed the Driver Station Update, but apparently it didn’t take. After uninstalling and re-installing, the camera magically worked.

Wow, thanks a lot! That would explain why we couldn’t get it to work. We set up the username and password to be root:admin like the guide said, but we most definitely do not have the compass-like thing you are referring to. We’ll update the driver station and get back to you.

Also thanks for the pinging explanation, it will save us time in the future if we tried to debug this way.

Thanks again,

Well we got the new DS update up, but unfortunately there’s still no camera feed. We just downloaded the default C++ code onto the cRIO, with the v19 image. Is there something we’re missing? The camera box no longer says “Timeout in Camera Communication” or whatever it used to say before, if that is of any use. It’s just empty and white.

Another thread uncovered a potential issue that causes the camera to boot very slowly. As a test, let the camera boot for a few minutes and see if it starts working. If so, the issue has to do with the C++ code immediately requesting an image after a failed one. If this is the issue, I’ll look for the other thread.

Greg McKaskle

I don’t think this is the problem, as we’ve tried using the camera after letting it boot for a good 10 minutes (idle time while looking through code). Any other ideas? It seems other teams are getting their cameras to work fine but no dice for us. if I haven’t mentioned before, we get feed through the IP when it is directly connected, meaning that the problem must exist either in our code (which is apparently supposed to display the camera image automatically?) or the Driver Station, which we just updated.

Let’s get the silly and obvious detail out of the way: make sure the little on/off control under the video display window is ON.

Haha, yes the little control button is on on the dashboard.