SFX (SmartDashboard 2.0) with Driver Station

Hi guys!

So I am trying to set up SFX to open on default with Driver Station, and I’m having troubles. I followed the steps on this site (http://wpilib.screenstepslive.com/s/3120/m/7932/l/163010-setting-sfx-to-launch-with-the-ds), and I also followed all of their troubleshooting options. SFX opens from both Windows Explorer and Command Prompt, so that’s not the problem. The path is also correct. Is anyone else having trouble or success with this?

Thanks!

Katy
FRC Team Shazbots 1245
Project Manager
Head Programmer

Same as us?

No, we don’t have this error. See my reply to that post for more details on that specific error.

For us, SFX opens just fine, just not with Driver Station.

Can you post exactly what you have as the command to open the dashboard?

In the FRC DS Data Storage.ini file, this is the line to do that…

DashboardCmdLine = "java -jar C:\\Users\\Shazbots\\sunspotfrcsdk\	ools\\sfx\\sfx.jar"

I have tried a few variations of that line, including single slashes and putting quotes around the C:\… with both single and double dashes. None of those options work.

Could you try


DashboardCmdLine = "java -jar "C:\\Users\\Shazbots\\sunspotfrcsdk\	ools\\sfx\\sfx.jar""

Also make sure on the driver station that “default” dashboard is selected

I’m pretty sure I already did, but I will try again tomorrow just to confirm it works or doesn’t work. I’m home for the night without that computer so I’ll let you know as soon as I can try (probably tomorrow morning).

I’m also unable to get SFX running from the driver station (but am able to run it from the command line). My command line is

DashboardCmdLine = ""java -jar C:\\Users\\Joe-XPS13-W7\\sunspotfrcsdk\	ools\\sfx\\sfx.jar""

I’m running Windows 7 64 bit with 64 bit java. I just updated java tonight, so I’m running 1.7.0_51

It works correctly on my laptop and I followed the documentation exactly. When I get home I’ll post my configuration file.

Didn’t work… The “default” dashboard is selected, and I have tried various things like double clicking it and switching between the other options before going back to it.

I’m also running Windows 7 64. There are three Java updates/JDKs I have installed:

Java 7 Update 45 (64-bit)
Java SE Development Kit 7 Update 45 (64-bit)
Java™ 6 Update 24

I know SFX should only run with Java 7, and it will run on my computer.

I guess it’s also worth noting that last year we got the first version of SmartDashboard working, so we have been able to successfully edit the settings document so it changes accordingly. I haven’t tried that again this year.

Also make sure you are editing the config file when the driver station is closed other wise it will overwrite it when it closes.

Yep, I have been doing that.

Have you (meaning anyone who has it working) integrated it into your code? The code I have currently doesn’t use SmartDashboard, so I’m wondering if maybe you need to be using it for it to come up?

(sfx dev here) Shouldn’t be necessary. Do you have multiple JVM’s on your system by any chance?

On the system, here are the Java items that are installed:

Java 7 Update 45 (64-bit)
Java SE Development Kit 7 Update 45 (64-bit)
Java™ 6 Update 24

I believe they were just recently downloaded with Netbeans 7.4, though I was not the one to set it up. There shouldn’t be anything hidden. We recently reset the computer to factory default settings so there shouldn’t be any weird software from a long time ago installed that I’m forgetting about.

Also, I just tried referencing SmartDashboard and running that code, and it didn’t make a difference.

I only have 1, per the java uninstall tool. http://www.java.com/en/download/uninstallapplet.jsp

Well this is concerning… When I open the tool I don’t see the information, which would mean I don’t have java installed at all, even though I do… Are you running the newest update? I can try to download the newest version and then use the uninstall tool. Do you think that will help?

Well I went ahead and did it and it works! SFX now opens with Driver Station!

Note to the developer: maybe add that to the documentation?

And thanks to all the help!

So you uninstalled Java 6 correct? odd that there is no error message…