simple problem; can't build example projects

for some reason, I cannot build any of the example project except for the first one I created, the default robot code. When I right-click and build, it will show that it is building in the output below, but it seems to only create the directory, and stop there and show ‘build successful’. When you look in the directory(projectname/debug/), all you see is a makefile and no binary files .o files, etc. How do I fix this? thanks.

We had the same problem, have you tried different examples? Also, is everything updated on your PC?

Whenever this happens to me, and it happens almost every time I create a new instance of one of the sample projects, the problem magically goes away if I close and then reopen the project. I’ve seen a number posts where people closed Workbench altogether, and restarted it, to fix the problem. I’ve never had to do that.

I see… Thats what it says in the C getting started guide as well, but I swear I’ve done that before (shutting down windriver and restarting, then rebuilding). I guess I will try again.

Haha, that reminds me of an engineering joke I got the other day…

There are four engineers traveling in a car; a mechanical engineer, a chemical engineer, an electrical engineer and a computer engineer. The car breaks down. “Sounds to me as if the pistons have seized. We’ll have to strip down the engine before we can get the car working again”, says the mechanical engineer. “Well”, says the chemical engineer, “it sounded to me as if the fuel might be contaminated. I think we should clear out the fuel system.” “I thought it might be a grounding problem”, says the electrical engineer, “or maybe a faulty plug lead.” They all turn to the computer engineer who has said nothing and say: “Well, what do you think?” “Ummm perhaps if we all get out of the car and get back in again?”
sorry about being off topic, i just thought I could lighten the mood a little :slight_smile:

lol, that was pretty cool. It is relevant though, since it is like turning off/on a device ;].

Another thing that may help is to right-click the project then select Build Options->Clean Project in the context menu.
You shouldn’t have to do any of this, but it is what it is.

You know there’s a Build Project and Rebuild Project in the context menu.
You should be using Rebuild.

Edit: Sorry, I didn’t really catch that you typed “build” (as opposed to rebuild) when I read your first post.

hmm, my post didn’t go… anyways, yes I have tried cleaning then build, and rebuilding as well.
I will probably dedicate all of tomorrow to build other examples, and to get the joystick working :stuck_out_tongue:

If you want to zip up one of the problem projects and post the zip here, I’ll take a look at it.
I have a way with these things once I can see actual files.
If not, have fun tomorrow. :o

since I don’t have access to the files right now, I will post it tomorrow and have fun tomorrow x]

“Ummm perhaps if we all get out of the car and get back in again?”

“And be sure to close all the windows first.”

woow, fail on my part; looks like the computer engineer was right. I tried creating the project, closing windriver and restarting windriver, then building, and it worked. Thanks for the help guys :). I will be posting another question though, but this one is solved. Thanks again.

curious, i’ve always just deleted the makefile and then build it again. I’ve found this forces Windriver to actually create everything it should.