SmartChart (Graphing Plugin for SmartDashboardFX)

As we’ve used SmartDashboard 2.0 (SFX) over the last two years, we’ve found that the built-in graphing utility just isn’t good enough, so we made our own version.

It can be found at https://github.com/Nashoba-Robotics/SmartChart

Advantages:

  • Graphs based on time, instead of based on when a new data point is sent to the dashboard
  • Graph can be reset
  • Graph can show multiple data sets simultaneously, by sending SmartDashboard a string with the format “[var1]:[var2]:[var3]”. Eg. “1.0:2.3:5.6”
  • Graph can export data to a csv file in the location USER_HOME_DIRECTORY/SmartDashboard/VARIABLE_NAME.csv

To install, download the most recent release, and move the .jar to your USER_HOME_DIRECTORY/wpilib/tools/plugins/ folder.

BONUS: In the repo, there’s also a SmartDashboard USB Camera extension that flips the image upside down, so if you have an upside-down camera on your robot, the output is more useful for your drivers.

We used this last year. It was super useful (even when the rest of SFX wasn’t really all that great) :slight_smile:

We’ve now added zooming as a feature as well. So far it is only available when not graphing multiple data sets simultaneously, but that is planned.

We just added zooming while graphing multiple data sets.

I installed this plugin and am finding I cannot click the buttons ('Reset Graph, ‘Save Data’, ‘Zoom’, ‘Reset Zoom’ or ‘Prepare to zoom’). Instead, it just drags the entire widget. I am new to SFX and don’t know if there is an Editable mode like the regular SmartDashboard that I am still in or something. I have looked around the settings and can’t find anything to suggest this. Does anyone know the cause of this symptom?

Yes, you have to press the green play button on the bottom right corner of the screen. It acts similarly to the Editable mode for the regular SmartDashboard.