SmartDashboard 2.0 launch issue

I’ve been trying to start the new javafx SmartDashboard have run into the following error why trying to launch the jar extracted from the zip:

C:\Users\TEAM 4334\sunspotfrcsdk	ools\sfx>java -jar sfx.jar
file:/C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/utils/common_c
onverters.rb:29 warning: already initialized constant ARG_CONVERTER_SUFFIX
file:/C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/utils/common_c
onverters.rb:32 warning: already initialized constant NAME_TO_COLORS
file:/C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/utils/common_c
onverters.rb:138 warning: already initialized constant CONVERTERS
file:/C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/utils/common_c
onverters.rb:173 warning: already initialized constant ENUM_CACHE
file:/C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/utils/common_c
onverters.rb:176 warning: already initialized constant ENUM_OVERRIDES
Exception running Application:
#<NameError: uninitialized constant JRubyFX::Controller::FxmlLoader>
org/jruby/RubyModule.java:2684:in `const_missing'
file:C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/imports.rb:71:i
n `const_missing'
file:C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/controller.rb:3
34:in `get_fxml_loader'
file:C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/controller.rb:1
17:in `load_into'
file:/C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/core_ext/stage
.rb:82:in `fxml'
classpath:jar-bootstrap.rb:74:in `start'
org/jruby/RubyBasicObject.java:1536:in `instance_eval'
file:C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/module.rb:49:in
 `with'
classpath:jar-bootstrap.rb:73:in `start'
file:C:/Users/TEAM 4334/sunspotfrcsdk/tools/sfx/sfx.jar!/jrubyfx/java_fx_impl.rb
:119:in `launch_app_after_platform'
org/jruby/gen/InterfaceImpl570972409.gen:13:in `run'

Any help with the issue would be appreciated. I am running windows 7 and using Java 1.7.0_13.

We had a very similar issue. I think the problem is the space in the Username. Can you move the sfx folder to just the C: drive so it doesn’t have to go through the User account with the space? When you launch sfx it needs to make two other files, sfxlib.jar being one of them. I forget the name of the other. Even if the files exist already, the space in the Username is problematic for the system finding them.

We ended up making a different user account with a name without spaces and it worked just fine for opening. Although we haven’t been able to get it to open with Driver Station. (http://www.chiefdelphi.com/forums/showthread.php?p=1327293#post1327293)

I hope this helps!

(sfx dev here) hmm, thats very odd. This is the latest released build I assume? Does moving to a non-space user dir work?

Yes, we also had the same problem with being unable to launch SmartDashboard 2.0. The sfx directory had the sfx.jar file, but issuing the command “java -jar sfx.jar” resulted in an error stating that the file “sfxlib.jar” was not found.

The directory path had a directory with spaces, which was being translated by java into “%20”.

Moving the sfx.jar file to a directory with no spaces allowed the sfxlib.jar and sfxmeta.jar to be created, and the SmartDashboard was launched.

Also tried moving these two files into the directory that had a space, but still received the error that the sfxlib.jar file was not found, and the directory path had “%20” as the path (instead of a space), which is probably why java was unable to find the file.

Peter Rivera
Programming Mentor
RMR 662 - Rocky Mountain Robotics

I moved it it to the C:// directory and got the error mentioned in this post.

Putting this line into the FRC DS Data Storage.ini works for me - I have to switch to Java then back to default to launch it. Also it takes a second for it to show up.

DashboardCmdLine = “C:\apps\jdk1.7.0_51\bin\java.exe -jar c:\SFX\sfx.jar”

Things to know:
1: I installed java to the directory above so modify accordingly
2: I copied sfx.jar and plugins to a new directory called SFX right off the root of the C: drive.