SmartDashboard 2.0 (SFX) problems

I am trying to test SFX 2.0. I have installed it per the 2015 instructions on ScreenStepsLive. When I launch SFX, I get a completely blank screen. Nothing happens. If I move my cursor to the very left edge and wiggle it around I can get a menu area to slide in from the left, but it contains nothing.

What is the current version of SFX 2.0? The version I am running says Jenkins-SFX-31-2014-12-22 when run from a command prompt. I also see an error stating “double load detected”.

Ok…so complete miss by me. SFX is actually working, but the window it opens is so big that all the controls were off the screen and I had not resized it far enough for the tool bar at the bottom to become visible. Now that I figured that out, SFX seems to be working.

But, that issue of the size of the SFX window on start up is a problem as I want to run SFX over the top of the FIRST driver station window. How do you set the size of the SFX window on startup?

SFX developer here, and I’m not sure how you managed to get a huge window, but the default size is quite reasonable for most screens. Do you have a large DPI set or a very small screen?

You can’t directly set the screen size, but you should be able to resize the windows and save that layout and it should restore the size when you open the savefile again. Also, it may be helpful to get the exploded version of SFX:

I am running SFX 2.0 on a classmate so that may explain the screen size issue. So I tried resizing and saving a settings file and loading that. It did not resize. I also can’t get the settings file to load at run time. What exactly is the syntax to load a settings file on the Java command line?

A further problem is this:
I had the regular SB and SFX loading and running on the driver login on classmate while working at my office. While there are the problems with SFX desribed above, it did load and run on driver login.

Then took classmate to robot lab to try with robot and found that neither SB or SFX would load under driver login. Nothing happens as far as I can see. Both still work fine under developer login.

While SFX looks interesting, I am finding it unusable. It fails to save or restore settings. It is slow slow slow to start and to exit. It can’t yet prove it will start up setting screen size and location as (above) I can’t seem to save and load a layout.

Is SFX for real? Has anyone solved these problems and used it successfully?

Will the “exploded” version help?

SFX is on the screenstepslive doc and is delivered with First software tools but does not at all seem fully baked. What is the story here?

So I installed the “exploded” version of SFX as suggested. After some fooling around, I got it to start loading and it exploded. The error is “An old jar file (version jenkins-SFX-31-2014-12-22…guid follows) was found that differs from the current version (patrick-modified-nojar-3-31-2015).”

I do have the older version on the system but I renamed the jar so in theory it could not be found but the error persists.