SmartDashboard Crash

SmartDashboard crashes immediately when running Driver Station or when starting from Eclipse. Deleted default save, didn’t fix anything. Don’t know where to find logfile for crash. Running new 2016 FRC update and WPIlib.

Run SmartDashboard from the command-line and post the output.

java -jar C:\users\<user>\wpilib	ools\smartdashboard.jar

What version of java are you using? Post the output of

java -version

Sorry I should have checked this sooner. I ended up deleting wpilib folder containing smartdashboard.jar and redownloaded the plugins in eclipse. Worked like a charm but I did have to rearrange the dashboard layout. I’ll remember this for future reference though, thanks.

Hello, I am having the same issue where as soon as you launch the driver station and the smartdashboard loads, it crashes. I have tried reinstalling the c++ toolchain, and the deleting the eclipse plugins and reinstalling them.

Here are the logs from running Joe’s suggestions

Java version:

C:\Users	igertronics>java -version
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

running smartdashboard from cmd:

C:\Users	igertronics>java -jar C:\users	igertronics\wpilib	ools\smartdashboar
No Extension Folder
platform: /Windows/amd64/
Jan 10, 2016 2:55:27 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0
x80000002. Windows RegCreateKeyEx(...) returned error code 5.
NT: connect() to  port 1735 timed out
Host: roboRIO-2053-frc.local
NT: connect() to  port 1735 timed out

Loading from    C:\Users	igertronics\SmartDashboard\save.xml

Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
Loading SmartDashboard widgets....
        at java.awt.EventQueue.invokeAndWait(Unknown Source)
        at java.awt.EventQueue.invokeAndWait(Unknown Source)
        at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
        at edu.wpi.first.smartdashboard.main.main(
Caused by: java.lang.NoSuchMethodError: org.jfree.ui.RectangleInsets.<init>(DDDD
        at org.jfree.chart.axis.Axis.<clinit>(
        at org.jfree.chart.ChartFactory.createXYLineChart(
        at edu.wpi.first.smartdashboard.gui.elements.LinePlot.init(
        at edu.wpi.first.smartdashboard.gui.DashboardPanel.addElement(DashboardP
        at edu.wpi.first.smartdashboard.gui.DashboardPanel.setField(DashboardPan
        at edu.wpi.first.smartdashboard.gui.DashboardFrame.load(DashboardFrame.j
        at edu.wpi.first.smartdashboard.main$
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$400(Unknown Source)
        at java.awt.EventQueue$ Source)
        at java.awt.EventQueue$ Source)
        at Method)
        at$1.doIntersectionPrivilege(Unknown Sour
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at Source)

Any suggestions?


Alright, I figured it out. The reason the smartdashboard crashes is because you are using an old dashboard save from last year. To fix this just navigate to:


and delete save.xml.

Then it should work,. However, I ran into another issue when formatting different values on the smartdashboard. Whenever I try to change a simple text box to a line plot or simple dial, the value disappears and does not show up again until you reboot the dashboard. When it does reappear, it is just in a text box again.

If anyone can reproduce this issue or has suggestions, please respond.

I duplicated the problem and submitted a patch for review.

any idea when the patch will come out as part of an update?

It is in yesterday’s update.

This may be a silly question, but how do I get the latest update of smart dashboard? I came across this discussion as our team also ran into line plot issue. And firstforge website doesn’t seem to be available anymore. I tried teamforge, but couldn’t find the installation files. Thanks

Ditto on that nhchen. We’re running into the same issue with the lineplot and compass widgets disappearing. And we haven’t necessarily found the latest update of smart dashboard.