SmartDashboard not launching

Greetings, all.
I am trying to set up a driver station on a non-classmate laptop (Gateway, Windows). All worked fine until I tried to open up the SmartDashboard through the driver station software, using the C++ button. Nothing happens. I have tried downloading the standalone installer, and following the instructions, but it still does not open. Can anyone offer assistance?

It may be that it’s not finding the executable. In “C:\Users\Public\Public Documents\FRC” there should be a file whose name I don’t remember exactly but it’s something along the lines of FRC Data something or other (I can get the exact name if you want next time I can get my hands on our machine). In there there’s a variable that has the exact path of the dashboard. Try changing that to wherever SmartDashboard is and select the default dashboard on the driver station rather than the c++ one.

The file path Evan is referring to is “C:\Users\Public\Documents\FRC\FRC DS Data Storage.ini”. Full instructions on the procedure can be found at this page:

The C++ button should launch the DS if you have the C++ Workbench update installed on the machine.

To use the standalone installer or if the C++ button is not working for you, follow the instructions Domenic linked above.