Smartdashboard Problems

I am programming in Java and I created several auto modes I would loud up smartdashboard and they are there sometimes but at random times my auto modes disappear and when I make new auto modes the dashboard never creates them :confused: is anyone else having this problem ? Are there any other fixes or options out there ?

This is a known issue and will be fixed in the next release of WPILib (sometime this week). For now, please restart the SmartDashboard to make your SendableChooser appear.

WPILib 2017.3.1 is released! Make sure to update to see if the bug fix worked for you.

How do you download this update?

  • Fire up Eclipse
  • Click the menu Help->Check for updates
  • Follow the instructions and accept all licenses.

I just downloaded this update, and re-downloaded our code to the Roborio, and the software keeps resetting. When I disable the camera, it seems to be okay. I do not get any errors on the driverstation. I get a warning “No code”, the Roborio resets, shows green on Code, and then prints another error and repeats. This is the same software we have been running. We are running Java. I tried reimaging the roborio, and redownloading Java, but same problem. I do not get any error (like robots don’t quit).

That means your code is crashing. What does the DriverStation console say?

So Our team tried downloading this update on 3 of our computers. One worked fine, One said there was no update needed, and there was on that gave us an error saying “Some sites could not be found.” Is this a bad thing? Any info is greatly appreciated. :]

There are no errors in the status box. If I switch to show warnings, the warning is the no code error, which repeats each time the code is restarted.

I am currently using DS 17.0.1, Lib: 17.3.1

When I tested the sample code provided, while the code does not crash, it does not display the Blur view (when selected, video is disabled). As best I can tell, there seems to be an issue with the source/sink setup.

Does this sample still work as expected under the new library?

protected void capture_test() 
  UsbCamera camera = CameraServer.getInstance().startAutomaticCapture();
   camera.setResolution(640, 480);                
   CvSink cvSink = CameraServer.getInstance().getVideo();
   CvSource outputStream = CameraServer.getInstance().putVideo("Blur", 640, 480);
                Mat source = new Mat();
                Mat output = new Mat();
                while(!Thread.interrupted()) {
                     Imgproc.cvtColor(source, output, Imgproc.COLOR_BGR2GRAY);

At first glance, that sounds like a networking issue. I would try on a different network to see if the update sites are blocked on the one you have already tried.

Found the problem. cvSink.grabFrame (source) will sometimes return empty images, which cause exceptions downstream. Adding a check for empty images corrects this.

if (source.empty()) continue;

Entries for autonomous using the SendableChooser still appear in a random order on the SmartDashboard, even after the update. Any way to enforce a particular order of the entries?