Software update?

How long has this been posted?
http://joule.ni.com/nidu/cds/view/p/lang/en/id/1534

I knew NI had said they would issue an update but hadn’t heard anything about it, so I checked the website. I now have cRIO image v20, up from v19.

Eric

Looks like the Driver Station also has an update. Version 1.1

http://joule.ni.com/nidu/cds/view/p/lang/en/id/1535

Mike U.

Interesting that they haven’t posted anything about it on the FRC website…

I just stumbled on to these updates this morning!

It would be nice if the NI site gave the actual date of update
in the Release Date field - it says 01-2010 although
the update seems to have come out yesterday.

The US FIRST site says the update is from 09-Jan-2010 !

To sum up as of this morning, there are 2 updates:

I have not yet applied either of these so not sure what may work or break after these updates! So save your settings etc., before you try these.

Thanks

they seem to be behind of updating updates. they just announced there were C++ and java updates (not from the 9th anymore): http://usfirst.org/roboticsprograms/frc/content.aspx?id=10934

Where did you find the v20 update? We still only have v19.
Thanks!

Have you installed the labview update?

FROM LABVIEW UPDATE DESCRIPTION:
Because this software also contains the update to the cRIO Imaging Utility, teams using Java and C/C++ will also need to install it.

It would also be nice to know what was updated. For example, we submitted a concern on the FIRST forums about the DS not reading the d-pad on a gamepad correctly. We have since worked around this by adjusting our control scheme, but it would be nice to know if/when it’s fixed so that we can go about our original plans.

Has anyone found release notes? I haven’t installed it yet, but I don’t remember any release notes on the last update. Maybe I’ll come across it this time.

we updated to v20 today and now netbeans is complaining that we’re on v20 (it’s looking for v19) any thoughts?

thanks

We are in the same situation…did the mandatory labview update, updated the CrIO, which is now at v20. NetBeans now gives us the message, “Expected version FRC_2010_v19.zip;”

This is probably why it wasn’t announced yet. I’d reccomend going into Tools > Plugins, and checking for updates there.

We have the exact same problem, anyone have any thoughts?

I saw this this morning, and downloaded and installed the update.

Don’t make the same mistake. Netbeans refuses to download code (as others have said, because it’s looking for image v19).

After scrounging the v19 image off of another machine, I tried reimaging with the updated software. I must’ve tried 5 or 6 times with no luck on two machines. Reimaging with a non-updated machine worked like any other re-imaging.

Downdating with the v2.0 LabVIEW update won’t work because there’s a newer software version installed. You’ll either have to uninstall and reinstall the software or find another computer to reimage it.

After the successful reimaging, I’m now having an issue where I get:

Connecting FTP @10.15.33.2
upgrade:
Sending local file image.suite
flashapp:
deploy:
init:
Waiting to connect to OTA command server of 10.15.33.2:8001 for past 11s

which never completes. But it might need to go in another thread.

EDIT: Nevermind, I just had to let the cRIO sit, off, for a little. Code now downloads.

If you follow the link for Jan 9th updates, you will see that they are pointing to the new versions now.
:mad:

After applying the patch 4.2 to fix the problems created by C++ update 4.1, We get the “reference to undefined symbol” errors for
_ZN10AxisCamera11GetInstanceEv … etc.

We are having the same problem with “undefined symbol” error for ZN10AxisCamera11GetInstanceEv. Has anyone figured out a way to fix this?

The link to the following list of changes was posted on the NI FIRST community: http://digital.ni.com/public.nsf/allkb/487FB316344500E6862576C8004CC32D

  1. Has anyone successfully installed these updates and overcome all errors?
  2. Any idea what happens to project work done/saved in Labview before the update, after the updates are installed?

I’ve tried to update http://controlsystem.neofra.com with the latest software links in the table on the top of the main page, to the best of my knowledge.

Let me know if I missed something.

Your code remains untouched.
Just Build again after the LabVIEW update and reimage the cRIO before downloading it.

P.S.
I didn’t have any issues with LabVIEW.
I’m working with Windriver now, but haven’t tested yet.

Thanks, Mark…