Solenoid Break Out Power Help


I could use a little help with powering a solenoid break out. I have followed all of the instructions and done quite a bit of research. I have connected my breakout to the PDB with a 20 amp breaker and then to a Wago and onto the Breakout. I do not see any light from a Power LED. I do see the LED on the solenoid block that toggles between two different solenoids. I used a multimeter to test the power and we have nothing going into breakout. I have tried a new breakout and that didn’t work either. Any suggestions

It would be useful to see a picture, because we can’t help you without knowing what you’re doing. That being said, what you have described is correct, but you should see a green power LED on the solenoid breakout when the power is connected to it, even if it’s not plugged into the cRIO.

What do you mean by solenoid block? Do you mean a valve, or the module that plugs into the cRIO? I’m assuming by the lights on the block, you mean the 8 green LEDs on the cRIO module.

If both breakouts aren’t faulty, then the power isn’t making it to the solenoid breakout. (just to clarify, this is a breakout)
This could be because the power board isn’t powered, you don’t have the fuse in the right spot, the fuse is broken, the cable isn’t inserted properly into the power board, the wires aren’t in the wago connector the right way, or the polarity is flipped.


Thank you for the reply. I will try and take some pictures this afternoon when working with the kids. To clarify a bit…the Solenoid Breakout if plugged into the Solenoid Module. I have Crio-II and the module is plugged into the third port. On the module there are 8 LED lights. The software is programmed to activate the double solenoid on pins 2 and 3. When we activate the telop mode I have LED #2 lit up and can toggle between 2 and 3 which I assume tells me that the code is working?

I have tried to power the breakout in several ways. I first tried using the PDB board. I definitely made sure I had the correct polarity, switched breakers and even switched ports on the PDB board. None of them caused the LED Power light to light up on the breakout. I then tried to connect the breakout to an external power supply of 12 volts DC and this also did not get the LED power light to light up. BTW I have looked at the break out and it doesn’t even look like there is a LED there. It just looks like a tiny hole where they say there is supposed to be and LED. (I have the break out revision 4).

Ok, so using what we told me about the breakout and how it can be powered when not connected to the Crio….I did more testing this morning and found out that 1 of the two breakouts I have is bad. I replaced the breakout re connected everything and everything is working. Thanks for the help! I would have pulled my hair out continuing to trouble shoot if I you didn’t give me that advice!