Solenoid Exhaust Not Allowing Build Up

Our 12 VDC solenoids keep pushing air out of the exhaust ports upon starting the compressor. When I cover up the port, the leak will stop occurring. Every once in a while, it will switch to the other exhaust port. It has also jumped to another solenoid. We aren’t using a manifold; just two separate solenoids. When we drain the pneumatics and try again, the leak usually occurs again. We thought that it might be the solenoid, but we have tried it with three different solenoids and it still persists. The code for controlling them has not changed since before the problem occurred, and the solenoids are receiving about 11.9 VDC when initially activated. We have redone the fittings into the solenoid as well. Does anyone have any ideas as to what is happening and how to fix it?

It’s usually a bad cylinder letting air past the piston.

So the air would just be going into the one side of the piston, past the plate that it normally pushes against, into the other side of the piston and then out the exhaust port?

Past the seal yes. A little tiny leak can make a big diference.

Okay, thank you. We will try replacing the pistons tomorrow. Just to cover all of our bases, is there anything else that it could be?

Not really, the exhaust can only be coming from the cylinder or the solenoid and you tried that.

1 Like

So we swapped out the old piston and the problem persists. We are going to try a new set up with just one piston to ensure that it isn’t the pistons. We are thinking that we have to change the solenoid again because this one had the problem and may be broken because of it.

Could you post a picture of how your solenoid valve is connected to the piston?

  1. Is this a single or double action solenoid?
    If double action, the solenoid may be in a neutral position and you will need to manually actuate it.
    There should be a two blue buttons (in the case of SMC solenoids) on the top if the solenoid. while the compressor is pressurizing, press one of them down with a pen or small Phillips screwdriver. That will manually actuate the solenoid. Be careful about the attached cylinder when you do that, it will probably extend or retract and someone could get hurt.

Could you also post what solenoids you are using?

I have observed this issue on our robots before and I believe it is related to the internal piloting on the solenoid. When the air pressure is too low, the solenoid spool can get stuck or pushed to an intermediate point that then exhausts the air and prevents pressure from building enough to pilot the valve into position. At work when we want to run a very low pressure through a solenoid I have to get an externally piloted solenoid so I can supply a high pressure for spool actuation.

1 Like

This type of leak can also be caused by a damaged or improper solenoid gasket.

Our team has also been seeing this issue with one of the double CKD solenoids from AndyMark (am-2343a). When attempting to build pressure from 0, one of the exhaust ports will be leaking and will not let pressure build over 30psi. When putting your finger over the port, it will build pressure. Sometimes this is enough to get it to seal back up, sometimes the solenoid needs to be activated to get it to shift the other way first.

Here are some photos of the set-up. We have two 6" Bimba pistons, double action. They both receive air from the one solenoid. I need to double-check, but I believe we are running the pneumatics at 35-40PSI.

So we need to ensure that the solenoid is actually engaged upon enabling the bot?

We have also used this solenoid with the same issue occurring.

The pilot pressure for that valve is 1.5bar (~22psi). When starting the robot you will need 22psi for the valve to respond to the electrical signal, I suspect that it will also require air pressure to respond to the manual override.

When starting the robot from 0psi I think your only option is to cover the exhaust port with your finger until it builds to 22psi, then it should actuate to a sealed state.

By manually actuating, Warren means to push one or the other of the blue buttons on the 4/2 side of the valve. It looks like one or two of these buttons may be blocked by tie wraps; this could conceivably be the source of your problem.

The zip-ties aren’t blocking the buttons. When we tried to do it while enabled, nothing happened at all. It still works when it is disabled, but that doesn’t affect its performance while enabled.

So we are currently starting with no charged pneumatics in a match. Would we need to leave the ports covered then? Doesn’t that hinder the actual function of the exhaust ports?

You can’t leave the ports covered, that will slow down or stop any pneumatic motions. You should start the match with air pressure. This issue is part of why you are allowed to charge the air on your robot before the match starts.

If you absolutely cannot start with pressure, switching to a single action solenoid might help a little bit, or you can try to find a non-piloted valve to use instead.

We found a new way of pre-loading our power cells, so we can start the matches with charged pneumatics. We have been trying everything that people have been saying with a couple of solenoids that had the problem; at this point, we think the solenoids is broken but we can’t find the unused replacement one to check that. Thanks to everyone for the advice!