Solenoid not firing off Solenoid Breakout

We’re can’t get a signal out of the pneumatics bumper to fire a 12V SMC solenloid. The power is okay to the module, and I’ve tried two different modules on 12V and 24V power. We’ve tried the sample VIs in LabVIEW and building the code ourselves. Anyone else have this problem?


Team 126

We had this problem earlier today. It ended up that we had a faulty solenoid module on the c-rio, and a faulty SMC.

When you run your code to fire the solenoid (try to use their example because it WORKS), activate the solenoid with the LV control. When you activate it, there should be a little LED on the solenoid module on the C-RIO that turns on. (and off when you turn off the solenoid). If that doesn’t fire, then you have a faulty solenoid module.

After that, we replaced our SMC with a fresco just for testing, and that did the trick.

Hopefully this will help!

Actually, we had a faulty solenoid breakout on the c-RIO and a faulty FRESCO solenoid. :stuck_out_tongue: Also, check the polarity on the FRESCO. For some reason, ours was switched which made the LED on the SMC not go on. (On a side note, we also had a faulty digital sidecar and a faulty spike relay, all in the same day. It was not a good day for us.)

Feel free to email me or pm me with any questions.