Solidworks Graphical Glitch

I wanted to bring to attention to a graphical glitch that I have found and solved in SolidWorks 2022-2023, which seems to be affecting an increasing number of users, in the community. On my machine it started around week 3 of competition season. When opening parts the first document to be opened would always look graphically correct. But when you open a second document it appears wireframe no matter what you do.

Example of what it looked like.

This is obviously a huge annoyance when trying to cad. When playing with the settings looking for the solution I came across a few settings that will fix the issue. The first one and least impactful on Solidworks performance is turning off “Optimize for thin part” under Options > System Options > Display


If deselecting this option doesn’t work for you another thing you can toggle is the “Enhanced graphics performance” under Options > System Options > Performance.


Hopefully this helps someone with the same issue.



Wish I tried to find this during season. You’re awesome.

I run into this issue every day at work. Definitely gonna try this out when I go into the office tomorrow!

1 Like

Another fix I found online (that worked for me) was to not use Game Ready GPU Drivers for Nvidia graphics cards and install Studio GPU Drivers.


I also had seen that this worked for some people. It unfortunately didn’t work for me as I was already on studio drivers when the issue first appeared.

This is also a good time to say if you are not using studio drivers you should be using them, the performance boost when modeling is worth the miniscule loses in video game quality, at least for me.


Parker brought this up to me a couple weeks ago when we were in a call and I happened to be screen-sharing and had the issue. This has been happening since mid-build season for me as well. Turning off the “Optimize for thin part” worked perfect for me, no issues since.

Thanks Parker, I’m guessing most SW users out there have been dealing with this issue. Somehow some kind of update that was rolled out at the end of January/February must have caused this.

1 Like