Solidworks question

I have been trying to learn Solidworks. Great program so far. I ran into a situation that called for using the toolbox, but the toolbox seems to be missing from my installation. I tried going into the add-ins and it is missing there as well. Any thoughts on what could be going on? Oh, I am using the Student Design Toolkit for the time being just to get familiar. It seemed full featured so I am not sure why the toolbox is not there. Thanks in advanace for any help.

I believe the toolbox is a Solidworks Pro add-in only.

I believe the toolbox is a Solidworks Pro add-in only.
Actually, the toolbox IS included in the Student Edition (plus other things like COSMOS). Afaik, they are not included in the Student Design Kit.

If you need to use the toolkit to insert fasteners and the like into your assemblies, you can also just head over to McMaster and browse to the page with the screw/bolt/nut that you want, such as p/n 91251A194 for example. For most of the hardware pages, there will be an additional button added to the grey bar at the top of the page that says “Download”. Click on that and select “3D SolidWorks” to download the .sldprt CAD file.

  • Just note that on many of those models, while the thread profile is correct, the thread itself on the CAD model is purely cosmetic. (Usually the threads are just ellipses instead of a helical shape). For most uses, it’s good enough.

Thanks for the replies. I have been downloading parts from McMaster and also the 3Dcontentcentral site. I was just hoping to progress to actually learning how to do it on my own also.