Solution to Ethernet Communications Problem with roboRIO

We have found a problem communicating with the roboRIO using an Ethernet connection. We could only use USB and thought that one of our Rios had gone bad. After a few weeks of troubleshooting we found a solution to this issue.

  1. Open NI Max and go to Remote System
  2. Select your Rio and click on Network Settings at the bottom of the screen
  3. Under Primary Ethernet Adapter change the Ethernet settings to DHCP or Local Link under the pull down menu
    If the adapter settings are DHCP only the roboRIO will not get an IP address and neither the computer nor the Driver-station will be able to communicate to the roboRIO.

We hope this helps others with similar issues,

Mech Tech 3959.

There appears to be a grammar error. Could you please clarify the intended meaning?

I believe that DHCP or link local should have been the default setting. Do you know if that was the case?

It is also possible to change this, if necessary, or to check it using the web configuration tool. Use a web browser and use roboRIO-team#.local as the URL. The fourth button vertically on the left is the ethernet configuration page.

Greg McKaskle

We are not sure how DHCP or local link was changed. We may have changed it inadvertently.