Spark Max Can TX and RX Sticky Faults

So our Spark Max is currently giving CAN TX and CAN RX sticky faults. We have ruled out the cable, and no matter what we try it is still giving us sticky faults. Also note that it is flashing between “Error Present” and “OK” constantly. Any suggestions?

Edit solved problem

Hey, how did you solve this issue? We are having the same problem with our robot and we don’t really know how to fix it?

Hi, as one of the main electronics members of my team I’d suggest thoroughly checking your can wiring and connections. If everything seems fine then check the connector of the spark max can cables and whether all cables are still properly attached (they tend to break off easily). Also make sure you’re using the spark max can cable v2, the other version has caused issues for us. If you still couldn’t get it fixed I could try and help you troubleshoot further.

Duplicate CAN ID

Update: the issue has been solved. turns out we have been connecting the can wires to each other the wrong way(green to yellow, etc). We flipped them around and it worked like a charm.

Hi everyone! Reviving this thread as we are having this issue with a new Spark Flex.

To clarify:
(1) No duplicate CAN IDs.
(2) No yellow wire/green wire mix ups.
(3) All other CAN devices on the robot working as expected.
(4) When we deploy the firmware from recovery mode, we can run the motor from the REV Hardware client just fine. However, run the code and we get the CAN TX and CAN RX sticky faults.
(5) We swapped motor controllers to see if that was the issue with no luck.
(6) We tried cutting down the code to just run the motor when enabled, still no luck.

Any ideas or thoughts are appreciated. Thanks!

Replying for future searchers - our issue was caused by an LED subsystem that was overriding other commands. All is well now.

Final resolution - We had “addRequirements” for the intake subsystem in the LED subsystem which thereby defined the default commands in two places. Eliminating this line of code from the LED subsystem fixed the issue.

1 Like

Hey everyone! We’re currently having a similar issue with our sparkflex giving CAN TX and CAN RX sticky faults, as well as seeing multiple motors momentarily changing LED status and speed.

We currently have two motors that control our variable launcher angle, with the motor speed being run by a PID loop in the subsystem periodic. We found that we could replicate the problem when pushing the angle of the launcher far enough off that PID had to fight to move back to it’s target angle, momentarily changing the LED status and speed of numerous motors on the canbus.

This was best represented when running our launcher wheels from another subsystem at the same time. We had two motors on these launcher wheels that would be normally blinking green when properly running, but then both motors would very momentarily flash red at the same time and appear to either stop or try to go in reverse when the problem occured, before very quickly going back to full speed.

We checked all of our CAN connections, CAN IDs and requirements in the code to make sure those weren’t the problem, and we didn’t see any issues. If anyone has any other ideas for potential solutions that would be amazing. Thanks!