Spark Max Configuration Client Does Not Find Spark Max

We just got Spark max motor controllers to use them with the new NEO motors and are struggling to update the firmware and set the CAN ID on them. We connected the Spark Max directly to the computer with the robot off and updated the Spark max configuration client to the latest update. The computer still fails to find the Spark max motor controllers, it continues to say SEARCHING…

2 Likes

There is a known issue with some Windows 10 installs.
There are 2 dll files missing from the system32 folder.
MSCVR120.DLL and MSVCP120.DLL.

Reinstalling them by copying them from another PC running the same OS has worked for me.

Search CD and you will find another solution by reinstalling a specific 2013 version of an app that I can’t recall right now.
Just search for one of the two files above to find that answer.

I had a similar issue. I found the app that you were talking about: https://support.microsoft.com/en-us/help/3179560/update-for-visual-c-2013-and-visual-c-redistributable-package
I installed it and now it works fine.

Did you all remember to put the motor controllers in firmware upload mode? You need to do this the first time you connect to a computer.

We had difficulty with this too. When we followed the tutorial, it worked perfectly.

We used a different computer and then it started working thanks, sorry for late response.

Trying to connect to new Spark Max using V 1.0.0 Spark Max Client but keep getting connection failed.

I installed the microsoft update C++ redistributed listed earlier n the thread - no change
Peforformed a firmware update to latest firmware 1.4.0 with spark client and it appeared to work - says firmware was updated even though it always showed connection failed. After update still get Connection Failed.

Tried installing some drivers from another search - Connection Failed.

In Device Manager item shows up as Unknown USB Device (Device Descriptor Request Failed).

Running windows 10. Tried using another Win 10 machine with just the client installed without the patches - Connection Failed.

Any thoughts on what else to try??

Thanks for any help.

Bohdan

Did you ever figure out how to fix this?

Updates to the SPARK MAX firmware as well as to the Client have changed the USB driver used to connect via a Windows PC. If you are having issues in updating a SPARK MAX to 1.5.0 or higher, switching the device into Recovery Mode to update firmware is a good place to start.

I had a diff issue where the max would not appear over CAN. Phoenix tuner worked fine with CTRE devices but the Max client failed to locate either sparks I had in the circuit. Any idea why?

What firmware is the bridging SPARK MAX running?

What if you can’t get to recovery mode. I downloaded the client a few minutes ago onto a clean PC. (i.e. one that I bought last month with no previous Rev Robotics software on it. Windows 10, 64 bit) Just in case, I disabled the firewall.

Run the client install. Two drivers attempt to install. One failed. The client software doesn’t detect the Spark Max controller. When I plug in, I get the Windows “unrecognized device” USB error.

Plug in, unplug, restart PC, try different USB ports, all the obvious stuff.

Finally, the last obvious step, search for “spark max” on Chief Delphi.

The DFU driver is one of two drivers installed by the Client and is used for updating firmware. It may not install completely until a SPARK MAX in Recovery Mode (DFU Mode) is plugged in to the computer.

Preemptively finalizing the DFU driver installation by following the Recovery Mode steps before opening the Client can get the drivers correctly installed as well.

Just to clarify, the MAX is put into Recovery Mode by the user before opening the Client. When in Recovery Mode, the Client won’t “connect” as usual, but you will see the device in the “Network” tab. See the Recovery Mode Instructions linked by @Michael_Kaurich.

However, you mentioned the Windows “unrecognized device” error. Does this error occur only when the MAX is in Recovery Mode, only when it is connected normally (not following the recovery steps), or does it show up in both modes?

If Windows throws an error only when the MAX is in Recovery Mode, then try installing the DFU drivers separately.

In order to isolate the issue to the software/computer versus the connected hardware, let’s add to what you have already tried. Try a different MAX if you have one. Try flipping the orientation of the USB cable into the MAX. Try a different USB cable all together.

If nothing above works, please send us an email at support@revrobotics.com.

Latest. 1.5.1 right?

Yes, that is the latest as of this post.

Please elaborate on what you’ve tried for troubleshooting steps. Is this the first time you’ve tried to communicate over CAN to these MAXs, or have you successfully talked to them over CAN via robot code? In other words, we need to try to isolate the problem to the various possible sources, wiring, the computer, etc.

Are you able to see these MAXs when you connect to them individually over USB? What firmware are they running?

We did use Max’s over CAN last year with no issues. I was trying to configure the controller over CAN from the client so here were the steps I took"

  1. Tried different configurations of the CAN bus
  2. Reinstalled client
  3. Using different USB cables
  4. Firewalls and all that stuff turned off on laptop
  5. Tried resetting both Maxs and reuploading latest firmware

Over USB I did notice issues with it.

  1. Often times, the Max would not appear until I unplugged/plugged in USB multiple times or restarted client multiple times
  2. When it did connect, it would not show any firmware version for either controller
  3. Often I would get an error from the client saying to check that the backend server is running or to unplug/plug USB again
  4. Sometimes I could not even select the controller from the network menu to upload firmware. I would hover over the checkbox and the pointer would turn into an error symbol. I had to reset using the mode button and then I could select it and upload firmware. (But the client still wouldn’t show firmware version even after this)
    However, I had no issues configuring the controllers or running them from the client once I got them connected but never once did firmware version come up.
    Also, I just saw this thread so I don’t know if the changes in the beginning still apply or not so I will be able to try them tomorrow if that would change something.

I was having the same problem as David_Lame, but installing the DFU drivers separately fixed it. They failed to install initially when I installed the spark max client. Thank you for posting them!!

As a heads up on another issue, earlier on in my troubleshooting I tried checking for updates on the help tab in the client. This installed an updated client, 2.0.1, where the “scan bus” button was missing! reinstalling the client and leaving it at 2.0.0 fixed the problem.

2.1.0 is the latest. The scan bus button went away on purpose and there is now just the “Rescan” circular arrows at the top. Feel free to upgrade again!

We haven’t updated the screenshots on the web yet to reflect the change. Stay tuned.

Just wanted to stop in here and post what worked for us, after trying everything listed above.

  1. The MAX driver did not install correctly with the 2.1.0 client, but the separate driver installation worked.
  2. When connecting the MAX to windows 10 64-bit laptop, the hardware connection sound did not happen. This was double-checked to work by disconnecting/reconnecting the mouse.
  3. We changed the USB-C cable from some junk one we had my USB-C cable included with my Pixel phone. Both the connection audio in Windows and the Spark MAX client worked properly.
  4. I double checked it with an OEM cable I got from Amazon. It also worked first try.

So definitely check those cables! Not all cheap USB-C cables are made equally.

Just to check, was the cable you got with the SPARK MAX bad or was it some other USB-C cable?