Spark Max Configuration Client Does Not Find Spark Max

We did use Max’s over CAN last year with no issues. I was trying to configure the controller over CAN from the client so here were the steps I took"

  1. Tried different configurations of the CAN bus
  2. Reinstalled client
  3. Using different USB cables
  4. Firewalls and all that stuff turned off on laptop
  5. Tried resetting both Maxs and reuploading latest firmware

Over USB I did notice issues with it.

  1. Often times, the Max would not appear until I unplugged/plugged in USB multiple times or restarted client multiple times
  2. When it did connect, it would not show any firmware version for either controller
  3. Often I would get an error from the client saying to check that the backend server is running or to unplug/plug USB again
  4. Sometimes I could not even select the controller from the network menu to upload firmware. I would hover over the checkbox and the pointer would turn into an error symbol. I had to reset using the mode button and then I could select it and upload firmware. (But the client still wouldn’t show firmware version even after this)
    However, I had no issues configuring the controllers or running them from the client once I got them connected but never once did firmware version come up.
    Also, I just saw this thread so I don’t know if the changes in the beginning still apply or not so I will be able to try them tomorrow if that would change something.

I was having the same problem as David_Lame, but installing the DFU drivers separately fixed it. They failed to install initially when I installed the spark max client. Thank you for posting them!!

As a heads up on another issue, earlier on in my troubleshooting I tried checking for updates on the help tab in the client. This installed an updated client, 2.0.1, where the “scan bus” button was missing! reinstalling the client and leaving it at 2.0.0 fixed the problem.

2.1.0 is the latest. The scan bus button went away on purpose and there is now just the “Rescan” circular arrows at the top. Feel free to upgrade again!

We haven’t updated the screenshots on the web yet to reflect the change. Stay tuned.

Just wanted to stop in here and post what worked for us, after trying everything listed above.

  1. The MAX driver did not install correctly with the 2.1.0 client, but the separate driver installation worked.
  2. When connecting the MAX to windows 10 64-bit laptop, the hardware connection sound did not happen. This was double-checked to work by disconnecting/reconnecting the mouse.
  3. We changed the USB-C cable from some junk one we had my USB-C cable included with my Pixel phone. Both the connection audio in Windows and the Spark MAX client worked properly.
  4. I double checked it with an OEM cable I got from Amazon. It also worked first try.

So definitely check those cables! Not all cheap USB-C cables are made equally.

Just to check, was the cable you got with the SPARK MAX bad or was it some other USB-C cable?

Just wanted to chime in with an update. It took me a couple of days to get back to the lab to try things out.

Once I did the independent driver installation, it worked fine. One of the units I was working with had to go to recovery mode, but that worked just like the instructions said it ought to.

I’m glad you all were able to get things working! We released version 2.1.1 the other day with a fix to the driver installation issues some have been seeing.

Good luck this season, don’t hesitate to reach out to us if you have any questions!

We needed a longer USB cable than the one that came with the MAX, so it was a different cable.

We are also having issues communicating between the SparkMax client and motor controllers over USB-C.

We have tried multiple laptops with the latest client (2.1.1) installed, we have tried controllers from last season and brand new ones from this season. This is the error we are getting in the client:

Not sure what backend server this is referring to… Any suggestions?

The client software automatically runs the backend ‘server’, this message means something is not working with it for some reason.

Does the issue persist after rebooting the client?

The application generates log files, can you can find them at “C:\Users<YOUR USERNAME>\AppData\Roaming\REV SPARK MAX Client\logs” and send them to support@revrobotics.com? We can take a look at see what is going on.

Good evening,
I hope someone can help.

I’m battling with the CAN connection to SPARK MAX controllers using the Client.
Here are a few pics.

I keep getting the connect and disconnect messages repeatedly for the two controllers not connected to USB.
Sometimes I get a system error that tells me to check the error Log, but the error message is not very enlightening.

I tried:

  • New USB C cable
  • Re configuring the Spark MAX controllers ( V1.5.1)
  • Re addressed the controllers individually with the client.
  • Added two 110ohm termination resistors to the CAN bus (one on each end)
  • Did a reset to factory on all 3 controllers.
  • Re installed the client in administrator mode. (Server version 2.0.0, Client version v2.1.1)

I’m running windows 10 PRO 64bits
Version 10.0.17763 Build 17763

Here are the drivers info I found

Thanks!

Quick update,
I installed the client on another laptop running Window 10 pro, and the same behavior is happening.

A couple questions:

  • Does this happen every time you open the client?
  • Or does it happen when you press the refresh button and/or connect to a device?
  • How many devices do you have connected and can you confirm that they all have different CAN IDs?
  • When you reconfigured the controllers to v1.5.1, did you put them in DFU Recovery Mode?
  • If you connect to one of the devices that was repeatedly disconnecting/reconnecting, does the other device begin to exhibit the same behavior?

I would definitely double check all the CAN wiring between your devices as well.

Take a look at my answers under each questions.

Thanks for the reply

I would definitely email REV at support@revrobotics.com to see if they can help you out some more.

In the meantime, some things I would try:

  • Re-updating the firmware using DFU mode with the Client v2.1.1 on all the weird behaving Spark Maxes
  • Fully uninstalling and reinstalling the Client v2.1.1 (if you haven’t already)
  • Try running the command line utility to talk to the disconnecting/reconnecting Spark Maxes individually and see that’s having issues as well. This uses the same USB-CAN Bridge that the Client uses.
  • Add more Spark Maxes/substitute the Spark Maxes you have with new ones (if possible) and see if the behavior persists on those new Spark Maxes as well

Hope this helps!

Thanks! I’ll try point 2 and 3 this morning, and followup.

Anybody can tell me where to find the command line tool to run connection tests without the Spark MAX Client?

Thanks

Locate the folder the SPARK MAX Client is located in (C:/Program Files (x86)/REV Robotics/REV SPARK MAX Client/) and open a terminal here. The command line program can be run with ./sparkmax.exe. Some things to try:

  • ./sparkmax.exe --help will show all the commands that can be run from the command line
  • ./sparkmax.exe list should list all devices connected over USB ONLY
  • ./sparkmax.exe list --all will list all devices connected over USB and CAN. Confirm that that ID’s on the devices matches those of what you have on your CAN bus. The ID’s are formatted as 205XX where XX is the CAN ID.
  • Once you confirm that you can see your devices with list, try getting the parameter table for each devices: ./sparkmax.exe --id 205XX parameter --all. Specify which device you want to talk to with the ID given from list.

If there’s issues talking to the devices, the command line should produce an error message as well.

Thanks! I will use this.

Also, I seem to have found the solution my problem.

I was using a 24 VDC Omron switching Power supply which normally does a great job, but must have been causing some EM noise and the problem.

I now have switched to an adjustable Lab power supply set to 13.4 VDC and the problem has gone away.

Since all robots are running on batteries, the problem won’t present itself, but take note that the motor controllers are not immune to EM noise and you need a good and clean power source to run them on a bench.

Thanks for your help.

1 Like

I have found that using dfu-util to flash the sparks with the latest firmware allows them to be detected by the client.