Spark Max Configuration Client Does Not Find Spark Max

Just wanted to chime in with an update. It took me a couple of days to get back to the lab to try things out.

Once I did the independent driver installation, it worked fine. One of the units I was working with had to go to recovery mode, but that worked just like the instructions said it ought to.

I’m glad you all were able to get things working! We released version 2.1.1 the other day with a fix to the driver installation issues some have been seeing.

Good luck this season, don’t hesitate to reach out to us if you have any questions!

We needed a longer USB cable than the one that came with the MAX, so it was a different cable.

We are also having issues communicating between the SparkMax client and motor controllers over USB-C.

We have tried multiple laptops with the latest client (2.1.1) installed, we have tried controllers from last season and brand new ones from this season. This is the error we are getting in the client:

Not sure what backend server this is referring to… Any suggestions?

The client software automatically runs the backend ‘server’, this message means something is not working with it for some reason.

Does the issue persist after rebooting the client?

The application generates log files, can you can find them at “C:\Users<YOUR USERNAME>\AppData\Roaming\REV SPARK MAX Client\logs” and send them to We can take a look at see what is going on.

Good evening,
I hope someone can help.

I’m battling with the CAN connection to SPARK MAX controllers using the Client.
Here are a few pics.

I keep getting the connect and disconnect messages repeatedly for the two controllers not connected to USB.
Sometimes I get a system error that tells me to check the error Log, but the error message is not very enlightening.

I tried:

  • New USB C cable
  • Re configuring the Spark MAX controllers ( V1.5.1)
  • Re addressed the controllers individually with the client.
  • Added two 110ohm termination resistors to the CAN bus (one on each end)
  • Did a reset to factory on all 3 controllers.
  • Re installed the client in administrator mode. (Server version 2.0.0, Client version v2.1.1)

I’m running windows 10 PRO 64bits
Version 10.0.17763 Build 17763

Here are the drivers info I found


Quick update,
I installed the client on another laptop running Window 10 pro, and the same behavior is happening.

A couple questions:

  • Does this happen every time you open the client?
  • Or does it happen when you press the refresh button and/or connect to a device?
  • How many devices do you have connected and can you confirm that they all have different CAN IDs?
  • When you reconfigured the controllers to v1.5.1, did you put them in DFU Recovery Mode?
  • If you connect to one of the devices that was repeatedly disconnecting/reconnecting, does the other device begin to exhibit the same behavior?

I would definitely double check all the CAN wiring between your devices as well.

Take a look at my answers under each questions.

Thanks for the reply

I would definitely email REV at to see if they can help you out some more.

In the meantime, some things I would try:

  • Re-updating the firmware using DFU mode with the Client v2.1.1 on all the weird behaving Spark Maxes
  • Fully uninstalling and reinstalling the Client v2.1.1 (if you haven’t already)
  • Try running the command line utility to talk to the disconnecting/reconnecting Spark Maxes individually and see that’s having issues as well. This uses the same USB-CAN Bridge that the Client uses.
  • Add more Spark Maxes/substitute the Spark Maxes you have with new ones (if possible) and see if the behavior persists on those new Spark Maxes as well

Hope this helps!

Thanks! I’ll try point 2 and 3 this morning, and followup.

Anybody can tell me where to find the command line tool to run connection tests without the Spark MAX Client?


Locate the folder the SPARK MAX Client is located in (C:/Program Files (x86)/REV Robotics/REV SPARK MAX Client/) and open a terminal here. The command line program can be run with ./sparkmax.exe. Some things to try:

  • ./sparkmax.exe --help will show all the commands that can be run from the command line
  • ./sparkmax.exe list should list all devices connected over USB ONLY
  • ./sparkmax.exe list --all will list all devices connected over USB and CAN. Confirm that that ID’s on the devices matches those of what you have on your CAN bus. The ID’s are formatted as 205XX where XX is the CAN ID.
  • Once you confirm that you can see your devices with list, try getting the parameter table for each devices: ./sparkmax.exe --id 205XX parameter --all. Specify which device you want to talk to with the ID given from list.

If there’s issues talking to the devices, the command line should produce an error message as well.

Thanks! I will use this.

Also, I seem to have found the solution my problem.

I was using a 24 VDC Omron switching Power supply which normally does a great job, but must have been causing some EM noise and the problem.

I now have switched to an adjustable Lab power supply set to 13.4 VDC and the problem has gone away.

Since all robots are running on batteries, the problem won’t present itself, but take note that the motor controllers are not immune to EM noise and you need a good and clean power source to run them on a bench.

Thanks for your help.

1 Like

I have found that using dfu-util to flash the sparks with the latest firmware allows them to be detected by the client.

Our students struggled with this yesterday, and I wanted to share what solved it for us.

In summary, there seems to be an issue with the SparkMax v2.1.1 client installer. It will work fine if an older version of the client already exists on the machine, but not for a fresh install.

The older client didn’t work either. But after we installed the older version, and THEN installed the new version, everything worked fine for us.

We still occasionally needed to put the SparkMax in Recovery-Mode but the client connected consistently.