Spark Max firmware update issues

We are trying to update the firmware on our spark maxes and we seem to be unable to connect. Our robot is on, the sparks are on, everything is in good shape but when we try to refresh outlr connection between the spark and the Spark Max Client, we get “server network issue: check that the backend server is running or restart the program” we’ve restarted the program and there have been two time where we managed to connect, but it hasn’t worked lately. And thoughts?

I kept having issues yesterday, the “fix” for me was to run the Spark MAX Client as Admin. Right Click > Run as Administrator

That seems to work. We are now faced with the issue of updating older sparks which need to go into recovery mode. We follow the steps in the manual but when we load firmware, it doesnt seem to do anything? Update: after trying to do a recovery mode, we went on to another spark and even though we were running admin, it had the same issue as before. Now I’m getting spammed with spark connected spark disconnected

We had this happen to us as well. There is a chance that it did work. Try updating in bootloader mode, then after it finishes disconnect it (in software if possible, then ohysically regardless). Finally, plug it back in, connect, and set the CAN index. It worked for us.

What is bootloader and how do I use it?

My current issue is with updating firmware on sparks that are older than 1.4. These have to go into recovery mode and after doing so, the rev manual says to click “scan bus” but such a button does not exist. Anyone have directions that I could follow to update these?

Make sure you are using the Spark Max Client version 2.1.1 (or newer). We had trouble with version 2.1.0 and 2.1.1 solved it.

1 Like

The way that the SPARK MAX updates firmware is through USB Device Firmware Update (DFU). Recovery Mode forces the SPARK MAX into DFU mode so that you can always recover a MAX even if the update process is interrupted or the file is corrupt.

Only the oldest of factory firmware must use Recovery Mode to update using the latest 2.1.1 Client. 1.0.376 and newer can be put into DFU mode through the Client. Older than 1.0.376 requires the user to put the MAX into Recovery Mode manually and the latest client will prompt you with those instructions if necessary.

However, we are aware of a bug in Client 2.1.1 with this prompt that will indicate the firmware update completed when it really hasn’t. The simple workaround is:

  1. Close the Client.
  2. Put the MAX in Recovery Mode
  3. Open the Client.
  4. Go to the Network tab and click the scan button to find the MAX and update the firmware.

As @dvanvoorst mentioned, your client is out of date.

Also, trying to see the Sparks effectively in the Client requires you to disconnect the CAN wire from the Rio and power cycle the robot. There’s a “locking system” on the controllers that won’t let you access them in the Client while they are connected to the CAN Bus.

We have found the connection process to be a little finicky. What seems to work is:

Disconnect the Spark Max from all sources of power source (USB, robot) - LEDs should go right off
Close the Spark Max client
Now reopen the Spark Max client
Now plug in the USB cable
Now press the rescan button

Here is what we see after putting the spark into recovery mode. This is with the installer that I just got off of the rev site. Unless the link on the software documentation is outdated, we are using 2.1.1