Spark Max not showing up in Labview Functions Pallete


#1

We have downloaded the LabVIEW API for the Spark Max and the Labview for FRC 2019 is installed and updated, but we still can’t find the Spark Max in the Functions Pallete. Any suggestions or has anybody else having the same trouble. We really want to test and see if the NEO’s will work, but not having any luck


#2

If you completely close down your labview application and re-open it, it should work. Also verify that the VI package manager confirms the installation.


#3

NI package manager shows as installed. Restarted Labview and it still does not show up. Have uninstalled through the package manager and reinstalled. Still no luck.

Open to any other suggestions.


#4

Can you check where the installation directory is for LabVIEW 2018, and if the files were extracted to the correct spot by the NI Package Manager?

The default location for LabVIEW is:
C:\Program Files (x86)\National Instruments\LabVIEW 2018

You should see a folder for REV Robotics here:
C:\Program Files (x86)\National Instruments\LabVIEW 2018\vi.lib\Rock Robotics\WPI\ThirdParty


#5

Labview and Rock Robotics show up in those directories


#6

@BCR-Jim here is the process I followed to show the libraries:

  1. Download and install the SPARK MAX Client
  2. Download and install the SPARK MAX LabVIEW API using NI Package Manager
  3. Reboot the computer
  4. Saw the library in WPI Robotics Library > Third Party > REV Robotics > SPARK MAX

I hope this helps you get up and running!


#7

To close loop in case anyone else has same problem, we uninstalled Labview, reinstalled and it worked just fine.