Spark Max on its own CAN Network

We had an issue today where a Spark Max didn’t show up on the CAN Network, but it was wired and plugged in correctly. If we removed the can connection, the devices further down the chain would stop showing up. When we plugged directly into it, it would show only itself and no can errors. The spark can run the motor fine.

We ended up replacing the spark, but is this a normal failure mode? Is there any way to fix it?

Did you make sure it wasn’t a duplicate ID with something else on the network?

1 Like

That didn’t work

Did you check for a connector failure like any broken pins on the can connector?

1 Like

There are two types of CAN connectors for SPARK MAX – the older one breaks the CAN chain if it is unplugged. The newer on has thin, short yellow and green wires in a small loop near the connector. Also, double check that you have unique CAN IDs – you can blink each ID from the REV Hardware Client, then make sure only a single SPARK MAX is blinking.

Were you able to see the Spark Max in the Rev Hardware Client if you connected to it directly via USB-C? Have you tried factory resetting it or updating/re-flashing its firmware?

The CAN Connecter was the older one, so when we unplugged it from the spark, the rest of the loop was also removed. I tried changing the id to a one we knew wasn’t being used and it didn’t work.

When we looked at the spark in rev hardware client, it only showed the one spark and it said the CAN Bus is ok.
We didn’t try reflashing it or resetting it.

We basically gave up and we are now using a falcon (we also needed a bit more torque)

1 Like