Spark Max only communicating when in recovery mode

We have one spark MAX that will only communicate when put into recovery mode, its not sensed in the CAN network and does not connect to the application when we plug it in. We at one point had it working, it was connected to a Neo 550 and worked very well. But it just stopped working and communicating. would loading an old firmware on it potentially work for this?

Does the Status LED indicate anything when not in Recovery Mode?

The LED does turn on but i cannot communicate through can or USB. ive tried multiple cables and multiple can wires

To clarify, what blink pattern is showing in the various states you’ve tested?

Please confirm the version number of the Client on the About tab.

What shows up in the Device Manager when the SPARK MAX is connected to the computer via USB in its normal mode, not recovery?

I have clarified the blink pattern and the client is up to date. i will test the device manager report when im in the lab next.

Please tell me what blink patterns you are seeing and what version you are running.

When on the bot, blinking allow blue for brake mode brushless, and when only usb c plugged in, its orange and blue for missing 12v

Were running 1.5.2 on it

I assume you are seeing Cyan Blinking (light blue) rather than Blue Blinking (dark blue) as listed on the Status LED Patterns I linked above.

This status code means you are not getting a valid signal over CAN from the roboRIO. Please check the following:

  • Check that your CAN wiring is continuous and not broken anywhere.
  • Check that your CAN bus polarity is correct everywhere (yellow-to-yellow, green-to-green).
  • Check that your CAN bus is properly terminated at each end. Terminated by the roboRIO on one end and the PDP with the terminator turned on at the other end.
  • Check that your CAN IDs in code match what you assigned to the controllers. However, this might be difficult if you are unable to connect over the Client:

Because you had it working at one point, I doubt you have a driver issue. Can you please elaborate on your previous statement:

  • Do you get any errors?
  • Do you see the controller on the Network Tab?
  • What is the version of the Client?

This is the firmware version number, not the Client version number.

  • Again, what does the Device Manager show when the SPARK MAX is plugged in normally (not recovery mode).
  • Please send screenshots of what you are seeing.

Without being in the shop with you, it is very difficult for me to help figure out what is going on. I need you to answer every one of my questions in detail.