SparkMAX CAN connection issue

Hi all! We’re having an issue with the two SparkMaxes that we’re running right now. We’re using them over the CAN bus with NEOs, but we have no connection to the motors.
Things we’ve checked:

  • SparkMaxes LEDs - both flashing purple for no connection
  • PDP LEDs - Green, no errors
  • All of our Talons on the same CAN bus run just fine
  • We can still see the encoder values from these SparkMaxes, we just cannot actually drive them
  • The SparkMax motor controllers should be good – they ran the motor when we plugged in using USB C and the desktop utility
  • We also swapped the NEOs to ones fresh out of the box and had the same issue
  • We factory reset both SparkMaxes, and updated their firmware to the latest version

At this point, we’ve checked everything we can think of. Does anyone know of any further things we can do to test or debug these motor controllers? We’re at our wits’ end.

1 Like

Honestly turning the bot off then on again (with a short wait) might work.

Otherwise perhaps try an older firmware version?

We’ve been having a similar issue and a mix of these seems to be working (for now)

Are your APIs updated to the latest version? The latest firmware won’t work with the older APIs.

This has been happening over the course of a few days now, so there have been many power cycles that could have fixed it. @Aree_Vanier

Yes, I forgot to mention in the original post, but our APIs are updated to the latest version. I checked with the chart you have on the software page to make sure they were compatible too. I might try downgrading when I’m in the lab tomorrow to see if that fixes the issue. @dyanoshak

Have you checked to see if the spark max is responding to commands (i.e. is the light turning red or green for reverse or forward)? It might be a motor stalling issue, or maybe if there’s a gearbox, it could just be freespinning inside if it’s not connected right. Those are the 2 issues we had.

I did check. When running it forward or backwards, they still flashed pink. It just makes this all the more perplexing to me.

Are the can IDs set properly?

We fixed the issue; we aren’t sure how. They were still flashing pink when disabled, solid when enabled. But when we tried to run the motors the LEDs wouldn’t changed to red or green, and the motors didn’t move. When debugging, we replaced one with a fresh NEO outside of the mechanism, and suddenly it worked for both controllers. We plugged the motor back in and it still worked. Our only theory is maybe the encoder cable wasn’t plugged in properly? It doesn’t make much sense because it wasn’t the purple/orange fault, and we had unplugged and replugged both NEOs multiple times during debugging.

Anyways it works now. If we find any source to the issue we’ll update the thread. Sorry to anybody experiencing the same problem in the future that this thread was inconclusive.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.