SparkMax/NEO Errors

So we have encountered an issue with 1 of our 4 SparkMax/NEO’s. Whenever we try to assign it a can ID, it would reset back to 0 when we reconnected to it. On top of that, after about an hour of trying to re-flash the firmware we encountered a “Brushless Encoder Error” (indicated by the status LED). We have solved a few other issues today but this one is persistent. Any help would be much appreciated.

We are trying to determine whether or not to send it back and try to get a new one. We have 1 not working, 1 working, and 2 untested. Will get back to see if we encounter the same issue with others.

Alright, we have found a solution. We have found that it limits the ID to a max of 62. So any ID from 0 to 62 works but once you go over 62 it resets to the previous ID (which by default is 0). Regarding the Brushless encoder error, I still don’t know whats wrong there. Hope this helps

Did you update the firmware? Some of ours seemed to be doing that before we updated.

Have you verified that “Select Sensor Type” on the “Advanced” tab in the USB client is set to “Hall Effect”? If you have the controller set to brushless mode but the encoder is set to “No Sensor”, you’ll get the brushless encoder error LED pattern.

Yes, it was set to hall effect

The error began to appear after the firmware update

We’ve only tested one of ours (one NEO with one SparkMAX), but had this exact problem persistently. I posted here, so you may want to watch there for an answer as well. I also tried various values for the sensor field on the Advanced tab. Firmware matches the “latest” listed on the SparkMAX software resources page, but firmware had previously read “v0.0.0”.

We’re tracking this issue here.

Perfect, thanks Will!

If you need any assistance testing/reproducing, I’ll have a testbench set up in a day or two using the exact devices that we were having issues with (on the chance it’s somehow device-specific)

Is there any update on solving this problem? We seem to be running into it as well.