SparkMax unexplained issues

So after mostly successfully working with the REV SparkMax last year, we are suddenly now experiencing weird issues with them.

We have 4 SparkMax units which simply won’t turn on, while being connected to the robot(PDP) or to the PC. 1 of those is deffinately with version 1.5.1, while the rest are unknown.

3 more units won’t turn on via PDP, but do turn on via the PC. All are version 1.5.1.
2 of those worked yesterday and now stopped. The 3rd one was able to turn on but stopped after we connected it to a NEO earlier today.

We tried returning the firmware and it doesn’t help in anyway.

Has anyone ever experienced anything similar to this?

Thanks!

1 Like

Double check your CAN network and make sure it’s routed correctly.

Does this explain the SparkMax not even turning on?
We will still check the CAN of course.

Define turning on?

The LED is off

First Guarantee it’s not a wiring issue. Make sure that the battery is plugged in correctly and there are circuit breakers in each port on the PDP where you are plugging in a motor controller.
if this is not the problem and they are getting powered, it would be helpful to know what the LED lights are flashing on the SparkMax. http://www.revrobotics.com/sparkmax-quickstart/#status-led. If no lights are showing at all once you “turn on” your robot, try putting the SparkMax’s into recovery mode and rebooting their firmware.

1 Like

If you plug the MAX into a laptop, with no 12V power on the red/black wires, an LED that is “off” means the MAX is in recovery mode. You would need to load firmware onto the MAX.

Also - quick note - if the CAN wires are exposed, pull out the CAN connector when you do this. Otherwise the wires may cross (like ours did, llol), and lead to a red/yellow blink on the MAX that can only be rectified by plugging the MAX into a full/terminated CAN network.

When those SparkMax are connected to the PC, no LED is on and the PC won’t recognize them. Tried with 2 different computers with the same results.

Another diagnostic we did is plugging all those 7 SparkMax instead of once that do work properly (PDP & CAN), and they still don’t turn the LED on.

If you’re using Windows 10, you should hear an audible “hardware added” sound when you plug the MAX in. If you did not, then either:

  1. The drivers did not install correctly (try again by uninstalling the client / reinstalling with the 2.1.0 client, OR search CD / REV’s site for the separate driver installation location)
  2. The USB-C cable is bad (pinched/twisted wires). Try to find a cable that came with someone’s smartphone - usually these are great quality and meant to withstand some abuse that the OEM cables can’t.

Also note that if the MAX is in recovery mode, the LED’s will never turn on, even on a robot. Contact REV and they’ll work with you to double-check it isn’t the laptop/windows being a pain.

for the 3 SparkMaxs that turn the LED on in the PC I can hear an audible “hardware added” sound, but for the others I can’t hear an audible “hardware added” sound and they also don’t turning on theres LED.

I also download the latest version of the SparkMax PC client to one of the PC (2.1.1) and i got the same results.

1 Like

Have you tried putting it into recovery mode directly to see if things sort out? I didn’t realize I had to unplug power as part of that process, which tripped me up.

Otherwise it sounds like you should contact REV support then.

Hopefully we can get you up and running. First, let’s clarify a few things:

Could you please confirm that all 7 of the controllers were successfully used last year?

Please describe your setup. Were all controllers on a test board or robot at the same time or did you connect them individually?

It sounds like you went through and attempted to update all your controllers to the latest firmware before the failures. Could you describe the steps you took to do this?

Could you clarify what you mean by “it doesn’t help in anyway”? Which controllers out of the 7 are you trying to update? I’m trying to understand if the firmware successfully updates, but the status LED still doesn’t turn on under PDP power, or if the firmware doesn’t successfully update.

1 Like

Most of all 7 controllers were use in the least year.

I connected each time one of the 7 controllers with 3 other SparkMax that working to the robot board. the 3 controllers that turning on there LED when they connected to PC stop to work after I connected them to NEO motor, before I connected them to the NEO motor they work.

2 SparkMaxs was working yesterday with the latest version (1.5.1) and now they don’t, 1 SparkMaxs didn’t turn the LED on when I connected him so I update him to 1.5.1 (when I update him i gave him power only from the USB), when I gave him a power form the PDP and didn’t connect a NEO motor he turn the LED on, when I connected him to a NEO motor he stop to turn on LED when he get power form PDP. all the others weren’t in the 1.5.1 version. now all the 7 controllers not turning on there LED when they get power from the PDP and connect or not connect to a NEO motor.

The 3 controllers that can be connected to PC I tried to install to them again the 1.5.1 version, the PC client gave a message that “firmware successfully updates”, but it didn’t help they still not turning on there LED when they get power from PDP.

I just a couple questions:

For these 3 Spark Max controllers, when they were connected to the NEO were they also connected to the PDP or the computer via USB-C for power?

Are the LEDs for these 3 controllers turning on when the Spark Maxes are connected to a computer using a USB-C and only not turning on when connected to the PDP? Also, are only 3 controllers able to connect to the PC? Do the LEDs on the other controllers not turn on when connected?

For this controller, what connectors are you using on your wires? Make sure all those connectors are secure. Also double check the breakers in the PDP to make sure they’re fully seated; they can be a bit difficult. If you could provide any photos of your wiring setup for the PDP, Spark Maxes and NEOS, that would be extremely helpful!

They were connected also to PDP for power.

Yes, they turning on there LED only when we connect them to PC.

Yes.

Yes, not turning on when they connected to PDP or to PC.

All the connectors are secure, we using the Anderson connectors. the PDP port is OK, I also tried to switch between PDP ports with more then one SparkMax that work with the others that not working and it didn’t help, the SparkMax that working fine is LED turn on but the others 7 controllers didn’t turn on there LED no matter what PDP port I use.

Please post or email us some pictures of your wiring for the different controllers and also your full setup. Without being in your shop with you, this is the next best opportunity to figure out what is going on.

Usually when multiple controllers fail one after another, or simultaneously, there is a major electrical problem, like reverse polarity to the controller power. Reverse polarity can cause immediate failure of the entire controller, failure of just part of the SPARK MAX (LED status over USB but not PDP), or failure over time.

We were able to plug in and rewrite firmware for 4 of the SparkMax, successfully.

Later when plugged in to the PDP (only power. No can/PWM/encoder) The LED is still of, even when plugged in to the same port where another SparkMax does work (LED on Pink).

Attached is a picture of the setup + 2 Spark Max - 1 working with the pink LED, one with the LED off. Switching between them doesn’t change the situation.

Also, when plugged in to the PC after rewriting the FirmWare, those SparkMax blink between red and blue - which doesn’t appear on the LED status on the documentation page.

Thanks everyone!

Please correct me if I’m wrong, but the two failure modes you are describing are as follows:

  1. Status LED on with USB only. PDP power doesn’t work.
  2. Status LED off with both USB and PDP power.

I suspect both failure modes are a result of damage to the internal power circuitry. Likely causes can be:

  • Overloading the 5V rail by exceeding the rated current.
  • Reverse polarity on the Vbus input.

Regarding overloading the 5V rail:

  • Have you attached any additional sensors or custom circuitry to the controllers besides the NEO?
  • Does the LED for this controller turn back on after unplugging the NEO?
  • Did you plug in the NEO while the controller was powered or did you turn off the main power before plugging in the NEO?
  • Did this NEO get plugged into all failed motor controllers?

Regarding reverse polarity:

Thank you for the picture. I see several Anderson connectors that are not coupled to each other. In my own personal team experience this can lead to accidental reverse polarity.

Ultimately, we will need to take a look at at least one of the controllers in our lab to determine what has failed. We also need to move support over to email so that I can better loop in my engineering team.

Please send us an email to support@revrobotics.com so that we can coordinate receiving a controller for diagnostics and continue troubleshooting.

Yes.

I don’t think this is the cases for the failure, all the others controllers (3 SparkMax) working fine and the were connected to the failures controllers when this happened. also i tried to power all the working controllers from the PDP and one from the PC (I use one of those that turn there LED on when they connected to PC only) and connected all of them with the same can bus cable and setup I use when it happened, in the SparkMax PC client I can see all of the 4 SparkMax that connected in the can bus (3 that working with PDP power and 1 that working only with PC power).

No.

No.

I turned off the main power before I plugged in the NEO motor.

Yes, this motor was working few days ago.