Spike Relays Not Working

Our robot has a spike relay that is wired up to control our claw via window motor. It was working fine, although we realize the window motor was stalling for at least a part of the time. However, yesterday it just randomly stopped.

What we have done for diagnosis so far:

  • On the digial sidecar, either the red or the green light next to the PWM cable is turning on, depending on which way we telll it to go.
  • On the other end of the PWM cable, when we put the black lead of a multimeter up to the black cable, and the red lead to the white, it gives about 4.5V
  • There is 12V in the correct direction on the spike input
  • There is a circuit breaker/fuse (we tried them both) on the spike, and the light on the spike is lit
  • Even when the window motor is disconnected, we do not get any power on the other side of the spike
  • There is a 20A cicuit breaker on the PD board
  • Robot is enabled, etc, etc; the Relay LEDs on the digital sidecar are ON.
  • I connected one end of a multimeter to common and the other end to each of the outputs (M+ and M-) and didn’t get any voltage

I’ll probably try putting the spike on different relay ports to see if I get anything.

Thanks for the help!

Pull and check the 20a fuse mounted in the Spike.
They burn out if stressed too much and have to be replaced.

and you probably meant there was a 20a circuit breaker on the PD…

We’ve replaced the fuse on the spike with both a circuit breaker and another fuse. We know it works because the light on the spike does not turn on when the breaker is not in.

Do you have another Spike to test the motor with with? i.e. do you know if it’s the spike or another component on the robot that’s causing the issue?

Did you try replacing it with a different spike?

What is the LED on the spike doing? it should change color depending on what signal it’s getting - if it doesn’t, then try replacing the PWM wire, or checking your connections on both ends to make sure they are seated properly.

We tested it with another spike, which didn’t work either. The light on the Spike is not changing. Is it maybe an issue with plugging the PWM cable all the way in?

If you can make the Digital Sidecar Relay LEDs alternate between green and red, the the Spike LED should echo the same colors if it’s communicating.

Yup, sounds like your PWM wire isn’t connecting all the way. Check that it’s seated properly on both ends, and that someone hasn’t accidentally drilled through it or pinched it between a nut and the frame at some point - that happened to us once!

We fixed it; that was the problem. We’re going to hot glue the connector in this time!