Spooky Pneumatics Hub Issue

Hey all,

We’ve been using the new REV Pneumatics Hub all year and have been loving it. We’ve been to 2 regionals at this point and right before Semi’s all of a sudden we couldn’t build air in the pits. Lights looked all good, no voltage was going to the compressor. Called a timeout, couldn’t figure it out. However when we put it on the field it worked perfectly, thanks to our analog pressure sensor we could read that we were building air throughout the match which allowed for our climber to work. Got back to the pits, same issue, still couldn’t build air, but it worked on the field the rest of the day.

We used the exact same laptop and everything to hook up, code was unchanged. I have absolutely no idea what would cause that specific of an issue, any and all ideas are appreciated.

Thanks!

Is it wired to a fuse or a breaker? The fuses on the PDH are often intermittent.

1 Like

Is your CAN Id the default one? That caused us a few issues. Also we have had a few issues with the PH as well. I think that QC isn’t the greatest and I would try replacing it if you have another one handy. I would also try what Domtech suggested above first.

1 Like

Its currently in the dedicated PDH slot with a 20A fuse, not sure the fuse would explain how it was so specifically working on the field (especially under heavy defense). I have regular breaker slots open if needed.

I will check the CAN ID, but I’m fairly sure we had an issue with that earlier in season and already changed the ID. Worst case I do have a spare

Here are some links that might help you:

In particular, check:

  • What does the PH status LED show?
  • Does the compressor test mode work?
  • Have you tried updating PH firmware?
  • When you test in the pit, is it possible that your code is not instantiating any solenoids?
  • It might help us to help you if posted your code, especially the line where you call ph.enableCompressorAnalog.
  • It might help us to help you if you posted a photo of your Pneumatics Hub.

Ours would work intermittently while moving with it wired to a fuse, but you’d have to tap on the fuse to get it to start on the bench.

We had to replace ours - it appears a solder joint on the board where the switch connects is not good. Our second one is having the same symptoms. Contact REV. We added the old PCM to ensure we can use pneumatics.

we’ve had a similar issue this past week where we would lose comms while trying to compress in the pits. it turned out that the USB-B connection on our rio wasn’t the greatest so i would try plugging into either-net on your radio or rio.