Sporadic Drops of Robot Comms

My team is posting here after spending a fair amount of time troubleshooting this issue, any help would be appreciated.

Our issue presents as a half second or more drop in communications with the robot, with the Driver Station flickering to no connection and then back to enabled and driving. This loss results in the robot abruptly stopping, risking damage to itself and possibly dropping whatever load it might be carrying.

During this time the logs show major packet loss without a complete disconnect, with only voltage not registering. The error that accompanies it is:
Communications Timeout: # Input Voltage
Brownouts: 0.

The number appears to be the amount of times it has happened during that match. So far the most we’ve had is 21 times in 5 minutes.

We’ve so far replaced the router+power cable+Ethernet cable, VRM, attempted tethering directly and wirelessly, and had no luck.

We looked at the packets being transferred with Wireshark and found that we were having packet re-transmissions from the RoboRIO and then had the laptop read Duplicate Acquisition on said packets, 0.8 seconds before the DS log registered the Communications Timeout.

We haven’t been able to find anything at all about this type of error in the Driver Station log, can anyone give us any recommendations on further steps?

Thanks! I have attached both an example driverstation log and Wireshark log for the error, the duplicate transmission occurs at packet #19160.

**We’ve noticed that the mode LED on the RoboRIO shuts off when we lose these packets. That’s standard for disconnects normally, doesn’t help us much though. We’ve tried both our code and sample code.

1305 Wireless Issue.zip (450 KB)

1305 Wireless Issue.zip (450 KB)

It might help to know some more about the condidtions under which this happens. Is it in a room with little other wireless stuff? or at a scrimmage with lots of other robots?

Also a picture of your robot, showing the location of the radio, might help others help you figure out the source of the problem.

The conditions have been just us practicing with no other robots enabled nearby, in a college with no other wifi connections on our channel. But we’ve also tried a tethered connection as well which should have bypassed any issues that might’ve been caused by surrounding connections.

As for our robot, I’ve linked a few pictures of both it and the wifi channels.

If your radio has selected channel 7 and there is significant traffic on 6, you will wind up with quite a bit of interference. I also saw this at a local school. They took the camera off of auto channel select and set it to channel 1 and it worked much better.

Greg McKaskle

We’re having a similar problems. I’m too busy with work to help with the troubleshooting, but I’ll point my programmer at this thread. We’ve only tried wireless so far, so I’ll have them try wired tether tomorrow, as well as switching wireless channels.

If we were using a tether though, would wireless traffic impact the communication? I’m not too familiar on the intricacies of wi-fi, but I thought that was why we use tethers at events.

See if you can find a specific error in your driver station logs, they normally shed some light on what the cause may be.

Is there a background process running on your Driver Station computer that might be causing problems? Look for something like an auto-updater task.

We’ve had this happen on three separate laptops, one of which was mostly clean. We’ll look for a common program between them just in case.

We had an issue with our driver station dropping packages as well a couple days ego. Turns out AutoDesk updater was trying to connect to the Internet every 10 seconds or so causing us to lose comms with the robot. Unistalling autodesk from the laptop did the trick for us.

After going through four laptops, we haven’t found a common updater. Only one laptop which has quite a few installations actually has a steady connection, whereas our dedicated Driver Station Laptop and two programming laptops do not. We’re still stuck, and unsure how to determine if it is one of the few installations on these laptops.

Use the Task Manager. If you can’t identify anything obvious, start shutting things down. Either you’ll eventually find one that clears up the communication, or you’ll kill the whole computer and have to reboot.

These are useful tools to view, suspend, or kill running processes (Process Explorer) and to view and disable startup processes (autoruns):