Still no camera feed

So, after a week and a half, I have still been unable to get any response from the camera on the robot. I have been meticulously following the “2010 Camera and vision problems” thread, but to no avail. I am using Windriver to program.

First off, I’ll let you know everything that I have done. Initially, I tried to incorporate the camera code into an existing program, but now I’m just trying to get “2010imagedemo” to work. I have installed all of the updates and I am sure that the driver station has updated. I have updated the cRIO image and run the camera setup tool, verifying that the FRC account is there and that I can get a feed while connected directly to the computer. All of this has been done from both the classmate PC and our old programming laptop (even running it as the driver station). And to clear up any other confusion, it is connected to port 2 with a crossover cable and gray button on the driver station to enabled the camera feed is ticked.

The code builds fine and loads onto the robot. I then get the “watchdog not fed” message along with an error in the ‘Diagnostics’ tab:
“Fatal error “Task error: Task already deleted.” in HandleError() in C:/Windriver/workspace/WPILib/Task.cpp at line 188”
Note that no such file exists. Everything sits unresponsive for about a minute, then the watchdog error goes away and I can resume teleoperated, just with no camera feed.

Thanks for any help.


We’ve run into the same issue here as well. Pretty much the exact error, when attempting to use the 2010 demonstration code. We applied all the updates, including uninstalling and installing the Driver Update.

Can you verify that your console is showing a “s_errno_EHOSTUNREACH” error?

We’ve logged into the cRIO using the Console Shell, and attempted to ping using the following command:

ping “”,4

The pings were NOT successful.

Shouldn’t we be able to ping the camera through the cRIO Console Shell?

We “fixed” our problem tonight after experiencing the exact same issues as the OP.

It turns out, all our prior attempts to update the cRIO image to v19 failed, and we were running and older image on the cRIO.

After reimaging the cRIO with v19, we were able to get the DriverStation to view the camera feed, and our WatchDog not fed errors disappeared. We were only able to do this after DOWNLOADING the code however. We still have not been successful in getting camera frames in debug mode. It also takes a long time for the camera feed to start after powering on the robot, and one has to be patient enough to not enable the robot while the camera feed is being established.

Thanks for the suggestions. I’ll try updating the cRIO again. The DS reports v19, but the imaging tool was giving me a lot of trouble and I had to restart it a few times. If that doesn’t work, we’re planning on testing another cRIO with it. It may be a few days, but I’ll post again if I make any progress.

We had problems with the imaging tool as well. Ultimately, we ended up using the CLASSMATE the reimage the cRIO by directly connecting the two with the orange crossover cable from the camera. For some reason the reimaging tool kept throwing either a UDP communications error during cRIO reboot, or could not set the cRIO’s IP address.

Also, although it’s obvious, don’t forget to check-off “format controller” and select the v19 image when you reimage.

Lastly, I would be really interested in knowing if BEFORE you reimage, if you can open a Target Tools -> Console SHELL in Wind River, and try a ping “”,4

If you had the same problem as us, those pings should fail.

However, the moment you successfully re-image, before you load any code, if you ping again, it should work.

Thanks. I’m pretty optimistic that reimaging will work. I’ll let you know presumably on Monday how everything turns out.

Did your DS report v19 before you fixed it?

We’re having the same problem over here. :frowning: I’ll let you guys know if we make any progress.

I was saying on another thread that I had to go to C:\Program Files and manually delete the folder with the driver station software, then reinstall the software, before the feed worked. Just uninstalling and reinstalling the update didn’t work.

OK, our feed is working. I’m not really sure what did it but here’s what we did:

  1. deleted our current project and made a new 2010 Image Demo project
  2. added an FRC account to the camera
  3. ran the camera setup utility
  4. reformatted the cRIO
    After that, it was all good. If anyone has any ideas why this worked, I’d be glad to hear it.

If you never had an FRC/FRC account on the camera before, then the cRIO would have been refused login rights…

Our team has had the same problem as you. However, we recently fixed this and I posted detailed step-by-step instructions in this thread:
Hope this helps!

  • Mike and Team 2200

Finally got the cRIO to reimage without any errors…AND absolutely no change. I’m not worried about the DS update because I’ve been using another laptop that obviously never had the old version on it. I’ll still pull out our second cRIO, maybe tomorrow and try it. I’m happy that some people are having better luck than I am…

Hi there,

Have you tried installing the LabView update on the ClassMate PC? If you have tried everything else, this could be your problem. Most people develop on another PC and install this update on that machine, but not the ClassMate itself - because it doesn’t really make sense to do the update on a machine you won’t be developing with.

Anyway, this was one of the last steps we did on our way to getting an image. Try that if you haven’t already.

Also, are the Ethernet lights on port 2 on? Make sure you have a crossover Ethernet cable as well.

  • Bryce

Can you open a Terminal Shell in Wind River and ping the camera using:

ping “”,4


I was a little too quick with my last post. Turns out that the reimage worked, I had just tried so many things with the code that I needed to fix a few things there. I was never able get the console shell to launch in order to try pinging it.

One problem down, many more to be discovered. Thanks for all of the help everyone.