Strange Issue: Driver Station Will Not Connect Unless Rebooted

Hello, we at Team 3128 are having a very strange problem. Over Ethernet and USB, we can connect to our robot fine. But, when we connect over wi-fi, the driver station (and SmartDashboard and web dashboard) do not connect to the robot unless the laptop has just been rebooted. If I connect without rebooting and ping roborio-3128-frc.local, it does not find the host. It kind of smells like some kind of mDNS problem, but I have no clue what it could be. The driver station is a Lenovo Thinkpad T430, and these problems started summer 2016, around the time that the driver station upgraded itself to Windows 10.

At that point, we figured out that connecting an ethernet cable to the robot, connecting wifi, and then disconnecting the ethernet allowed us to connect normally. I figured that the problem was the Windows 10 upgrade, so I clean installed Windows 8 on the computer and put in a new SSD. That made it reboot faster, but the connection problems didn’t go away. Then, when I upgraded the driver station to the 2017 update suite, the Ethernet workaround stopped working.

I also tend to see the error “The mDNS service is slow to respond. Check firewall settings” in the driver station. I turned off the Windows firewall, and it did not solve the connection issues.

I also tried restarting certain NI network services, turning wifi on and off, installing Apple Bonjour (because it also supports mDNS) and disabling every network interface but wifi. None of these helped. I can only connect to the robot if it is the first network that the laptop connects to after booting up (though strangely, I can connect to another network, disconnect as quickly as possible, then connect to the robot, and it does work).

This error happens across at least three different robots (all of the ones we’ve tested), and occurs with the 2016 and 2017 wireless bridge. I didn’t test the older D-Link one.

Could there be something interfering with NI’s mDNS service? What could be causing this error? Why would it persist across Windows reinstalls? Could it be some kind of network driver update that got pushed last summer?

NOTE: I also posed this on the NI forums here, and got no response.

I may sound like a broken record, or I may sound like somebody who loves to beat Dead Horses.
My first suggestion is always to avoid using mdns if possible. I always recommend using static IP addresses on the RoboRio, driver station, and any other device on your robot like a RPi.

DS address should be
RoboRio should be

Devices like an RPi could be

Is it an issue with that one particular laptop? Try reconfiguring the radio or resetting it to see if there is any luck. I assume the radio does broadcast an SSID, but the laptop just cannot connect to it? :confused:

This issue happens with one particular laptop. It’s occurred with several different robots. When it doesn’t work, the laptop will connect to the robot’s wifi network, but the driver station and other programs cannot talk to the RoboRIO.

Good idea about the static IP though. I actually forgot that that still works with the new control system. I’ll try that tomorrow.

I am having the same issue … let us know how you do the static IP address. I am not sure what you mean with it but any assisatnce would be appreciated…

Your symptoms are the same… basically have to reboot the laptop to get the radio and rio to connect.

Our team had a similar issue early in the year when the FRC 2017 Control Systems was released for beta-testing. We tried it out since we were a beta-test team, and one thing that was noted was that we couldn’t connect to the robot on the field during an off-season competition. It was resolved when we changed the Static IP of the laptop though.

I don’t know if this might solve your issue, but I am just throwing that out there for consideration.

I keep reading this but i do not know what to change it to…

Where can i find the ip address i should put in there?

The NI mDNS service seems less reliable than it could be. If you know how to force it to restart, that usually clears up the kind of communication problem you are seeing.

A more convenient fix turns out to be installing iTunes. It comes with an mDNS/Rendezvous/Bonjour implementation that I’ve never seen fail.

just installed Itunes, reboot and still have the same issues… this is becoming very annoying.

Next step is to manually change the IP addresses… wish me luck…

Setting a static IP on the RoboRIO (in the network tab on the web dashboard, change the IP address dropdown to “Static”) did the trick for us. It works perfectly now. We didn’t even have to set a static IP on the laptop.

We tried installing Apple Bonjour a while back, and it did nothing.

1 Like